Syed Jahanzaib Personnel Blog to Share Knowledge !

September 12, 2011

208 Comments »

  1. Hi,
    I have configured this but I am having some problem. After log in into admin account. I have opened Facebook and It did open in no matter of time but is not loging in.

    Also in the script below you have entered wrong limit for 512 and 256kb
    Thanks

    add address-pool=hs-pool-1 advertise=no idle-timeout=none keepalive-timeout=2m name=”512k Limit” open-status-page=always rate-limit=5120000/5120000 shared-users=1 status-autorefresh=1m transparent-proxy=yes

    add address-pool=hs-pool-1 advertise=no idle-timeout=none keepalive-timeout=2m name=”256k Limit” open-status-page=always rate-limit=2560000/2560000 shared-users=1 status-autorefresh=1m transparent-proxy=yes

    Comment by Nouman Aziz — October 15, 2011 @ 4:49 AM

    • 1.AOA bhai kya ap mujy bta skty hain k hotspot main ip-binding main user ki speed ko kesy control kya jata hy.
      2.or main ny apny mikrotik se 8mb kisi or ko share krna hy or us ny bhi usy mikrotik se apny users ko share krna hy to es k bary main bta dain yeh kesy ho ga kyo k jab main mikrotik se usy net deta ho to us k mikrotik k routs main gateway jo k 192.168.0.1 hy us k agy reachable unknown likha ata hy yeh kesy ho saky ga k main usy bhi limit main rakh k net do or apny users ko bhi control kr sako plz help me .GOD Bless U.khuda hafiz

      Comment by Rauf Aslam — October 9, 2012 @ 3:32 AM

      • 1. For IP Binding, you can either use simple static Queues for each user ip. Or use PCQ to distribute bandwidth. Following is an example
        http://wiki.mikrotik.com/wiki/Cable_setup

        2. to provide bandwidth to lineman/distributor, just put his interface line into your any empty port of your routerboard, then create simple NAT sharing for that itnerface. on the other end, simply deploy net sharing, considering this lien as WAN for him.

        Comment by Syed Jahanzaib / Pinochio~:) — October 9, 2012 @ 4:27 PM

      • Asslam o Alaikum bhai ma 5.18 os use kar raha ho ma jab profile lagta ho 1 mb 2 mb etc tu request time ka error deta ha ping kro tu kbhi kbhi data ha ……jab dafult profile use kro tu request time out ka error nai data sub normal chalta…..or routerboard rb 750 ma server not found ka error data ha loadbalancing or hotspot kia ha is ka b solution plzzzzzzzzzzzzzzzzzzzzzzz………..

        Comment by waqar — October 9, 2012 @ 10:42 PM

      • 1:AOA sir plz yeh bta dain k aik hi mikrotik main hotspot or pppoe server aik sath kam kar sakty hain ya nai kyo k main ny line or wifi 2no ko control krna hy hotspot to pehly se configure hy ap pppoe kesy config krty hain bta dain thx
        2:bhai kya main ap se mobile pe bat kr skta ho plz ap mujy apna number email kr dain thx
        Khuda Hafiz

        Comment by rauf Aslam — October 11, 2012 @ 1:35 AM

      • 1:AOA sir plz yeh bta dain k aik hi mikrotik main hotspot or pppoe server aik sath kam kar sakty hain ya nai kyo k main ny line or wifi 2no ko control krna hy hotspot to pehly se configure hy ap pppoe kesy config krty hain bta dain thx
        2:bhai kya main ap se mobile pe bat kr skta ho plz ap mujy apna number email kr dain thx
        Khuda Hafiz

        Comment by raufaslam777 — October 13, 2012 @ 1:01 PM

      • Yes you can setup Hotspot and pppoe on same box, However It’s not recommended to merge both services on single box dueto some security related issues. few operators are running this model successfully.

        Comment by Syed Jahanzaib / Pinochio~:) — October 16, 2012 @ 3:05 PM

      • AOA
        1) sir i want to sahre internet to my user wirelessly.i give him a mt-link wireless router which is working as a repeater
        but when i put mac address of that router in ip-binding of my hotspot i unable to control bandwidth.it is taking all
        of bandwidth i have.please help me how can i control it.please tell me an easy way because i often cant understand
        your answers because im new user of mikrotik .

        Comment by Rauf Aslam — October 24, 2012 @ 1:51 AM

  2. Yes it was typing mistake for the rate limit. It is now corrected. Thx for pointing out.

    What exactly error you are getting while logging to face-book ? what symptoms ?

    Comment by Pinochio~:) — October 15, 2011 @ 10:36 AM

  3. When I click login, then the page starts to load but at the end I get this error ‘This webpage is not available’.

    Comment by Nouman Aziz — October 15, 2011 @ 2:04 PM

    • This is unusual error.
      Have you tried to open FB on direct link (Without hotspot) ?

      Comment by Pinochio~:) — October 15, 2011 @ 2:32 PM

  4. Yes. It does work fine without hotspot.

    Comment by Nouman Aziz — October 15, 2011 @ 2:40 PM

  5. Also how to create New Hotspot Profile in mikrotik. I want to limit up/down speed to 128k and want to limit time to 30days.

    Comment by Nouman Aziz — October 15, 2011 @ 2:40 PM

  6. on the login page this website comes up http://login.aacabke.net/status how do I change this?

    Comment by Nouman Aziz — October 15, 2011 @ 2:44 PM

    • you can change login name by going ip / dns and rename the name of your choice.
      or look at this entry

      add dns-name=login.aacable.net hotspot-address=172.16.0.1 html-directory=hotspot http-cookie-lifetime=1d http-proxy=0.0.0.0:0 login-by=cookie,http-chap name=hsprof1 rate-limit=”” smtp-server=0.0.0.0 split-user-domain=no use-radius=no

      just change the login.aacable.net according to your requirement.

      Comment by Pinochio~:) — October 17, 2011 @ 11:08 AM

  7. After configuration. Login page is not comming up. Can you please explain what the problem might be. I have also change dsl ip to 192.168.2.2

    Comment by Hamza — October 22, 2011 @ 12:55 PM

    • Most Possible Reason: DNS not configured properly. re-check your configuration.

      Comment by Pinochio~:) — October 22, 2011 @ 2:33 PM

  8. Hello, thanks for your tutorial, I have successfully set this up. Now I want to forbid access to some websites for my authenticated users. Any idea how I can do that?

    Comment by Bob Wood — October 31, 2011 @ 5:07 PM

    • Either block websites with firewall rule by ip address.
      Or the better way is to enable mikrotik web proxy and redirect all users to internal proxy, then using proxy rule, deny your desired websites.

      Comment by Pinochio~:) — November 2, 2011 @ 12:08 PM

  9. Salaam, I have done load balancing on 2 dsl lines. The LAN ip address is 10.10.10.1. So where in script I change this ip address?

    And How do I change logo of mikrotik?

    Thank you

    Comment by Nouman Aziz — November 16, 2011 @ 4:34 AM

  10. Replace 172.16.x.x series ip with your desired ip series.

    Comment by Pinochio~:) — November 16, 2011 @ 10:35 AM

  11. Jahanzaib Sir I have try to do this settings with my mikrotik DHCP has been established but On CLINT Pc I can’t connect with Internet I m Using PTCL BROADBAND servise

    plzzz help me about this

    Comment by Affan — November 26, 2011 @ 3:37 AM

  12. I have RB750. Now after doing the configuration. Do I need to connect crossover cable to clients port?

    Thanks

    Comment by Nouman Aziz — December 1, 2011 @ 5:56 AM

    • Crossover cable is used to connect PC to PC directly, why you wanna use it ?

      Comment by Pinochio~:) — December 1, 2011 @ 10:37 AM

  13. Someone told me that he is using cross over cable to connect to clients. But I know we use it to connect two switches or PC’s together.

    Thanks

    Comment by Nouman Aziz — December 1, 2011 @ 5:13 PM

  14. How to limit speed client speed who are in ip blinding list?

    Comment by Ayoob — January 9, 2012 @ 12:11 AM

  15. AoA
    I have configured my 4X Multi wan server as per your article. My network has static Clients. I am currently using pfsense firewall’s captive portal feature to enforce MAC authentication AND Bandwidth throtlling.. I mikrotik i have configured a basic hotspot. Disabled the DHCP server, but cannot enforce users via MAC. The Ip binding feature does not allow bandwidth limitation. I read on mikrotik’s forum that this can be achieved via IP>HOTSPOT>user and in the user name field “MAC address of Client” and pass field empty. but thats not working as well… Any work around for this.. other wise I am thinking about configuring another pfsense + lusca + zph for everything else and mikrotik Only for multi wan purpose.
    Thanks

    Comment by Nabeel — January 12, 2012 @ 6:15 PM

    • I am unable to understand why you are making this so complex while its very simple to accomplish this task.
      As you stated in your statement, that your clients are configured with static ips , (which is in my opinion a horrible scenario :P, even I don’t consider hotspot a very standard solution cable.network base setup’s its better to shift to pppoe , and you will sleep much better, with your both eyes closed ;) i hope u understand )
      Just create simple queue for your static ip client. What’s the hurdle in creating such query if you have static ip ?

      Comment by Syed Jahanzaib / Pinochio~:) — January 13, 2012 @ 11:21 AM

      • hmm ofcourse it is a nightmare to manage :) but we have a dhcp running (Connect Com) so we cannot have another DHCP. and for the problem mentioned above.. one temp solution i found was to create an ip firewall forward rule to drop packets based on source mac address. so that worked fine… but since we also need a proxy we are putting in place a pfsense + lusca and it’s captive poratal is preety neat. But thanks alot for these wonderful articles bhai.. you have really made things easy for us newbies. God Bless you.. Jazak Allah.

        Comment by Nabeel — January 13, 2012 @ 6:06 PM

  16. When I enable hotspot, I internet access is blocked rb450g

    Comment by Keith — February 10, 2012 @ 8:34 PM

  17. Hi,
    Assalam-o-Alaiqum,

    Jahanzaib bhai How are you?

    Thanks for your very good tutorials, i configured a hotspot with limited bandthwidth of Up/Down 128000/1024000 with customize login page. its working fine for only internet. when i ping to any computer or server ping is dropping. and also local sharing very slow. my question actually is, how to allow unlimited local lan speed except internet without login, and how to access my local webserver without login.

    i will be very thankful to you.

    Thanks
    Rashid

    Comment by Rashid — February 14, 2012 @ 6:06 PM

    • Local LAN traffic does not pass through router. This also implement on your web server or any other service , as long as they resides on LAN.

      Read the following heading in this tutorial and your problem will hopefully solve.

      HOTSPOT users can’t communicate with each other or PROXY-ARP issue

      If you face hotspot broadcast issue / arp-poisoning , problem, Remove the address pool from the Hotspot to turn off Universal NAT,

      /ip hotspot set address-pool=none
      OR
      /ip hotspot set numbers=hotspot1 address-pool=none
      OR
      /ip firewall nat add chain=pre-hotspot dst-address-type=!local hotspot=auth action=accept

      Comment by Syed Jahanzaib / Pinochio~:) — February 14, 2012 @ 7:02 PM

      • how could i find the broadcast issue or arp poising issue via any tools or with mikrotik router…?

        Comment by tamilmaran — June 21, 2012 @ 10:01 AM

      • This topic have been already covered many times on the mikrotik forum. Please search forum.

        Comment by Syed Jahanzaib / Pinochio~:) — June 21, 2012 @ 10:48 AM

  18. After configuration. Login page is not comming up. I can manually get to it at Ether2 IP address OR at http://login.net but for example say i try and load google.com I should be redirected straight to the login page right? Thats not happening. I admit I havent actually got my DSL router hooked up because its on site. Would the fact that its absent cause this error? When someone else asked above you said “Chek DNS settting” however I used ;

    /ip dns
    09 set allow-remote-requests=yes cache-max-ttl=1w cache-size=10000KiB max-udp-packet-size=512 servers=192.168.2.2

    But cahnged the last IP to suite my DSL router IP ~ any suggestions?

    Comment by Graham — February 18, 2012 @ 11:24 PM

    • the request URL must be resolved in order to get the login page :)
      so please connect internet on Mikrotik and then test the config.

      Comment by Syed Jahanzaib / Pinochio~:) — February 19, 2012 @ 7:42 PM

      • Yep – all working – great torial – maybe make this a .txt file download?

        You can copy paste into a terminal after manually edit the .txt file on your own pc :o)

        Comment by Graham — February 21, 2012 @ 1:04 PM

  19. AOA sir. sir i was trying to block mikrotik discovery when i was doing the following command manually
    add action=drop chain=input comment=”block mikrotik discovery” disabled=no dst-port=5678 protocol=udp
    when i set the Protocol = udp and was going to set the dst-port my router got discounted.
    now i can not access to my router. either i tried to access through web. i also can not access to my usermanger
    , plz sir help me what should i do now to access my router. plz sir help me.

    Comment by Suleman — March 5, 2012 @ 11:06 PM

  20. AOA sir. sir i was trying to block mikrotik discovery when i was doing the following command manually
    add action=drop chain=input comment=”block mikrotik discovery” disabled=no dst-port=5678 protocol=udp
    when i set the Protocol = udp and was going to set the dst-port my router got discounted.
    now i can not access to my router. either i tried to access through web. i also can not access to my usermanger
    , plz sir help me what should i do now to access my router. plz sir help me.

    Comment by Suleman — March 5, 2012 @ 11:07 PM

    • Are you using Mikrotik Router Board or x86 PC version?

      If using x86 PC version, login to your router (physically) and then use
      ip fi filter print

      then see the rules which is blocking winbox discovery and disable that rule like
      ip fir filter disable xx

      Comment by Syed Jahanzaib / Pinochio~:) — March 6, 2012 @ 2:20 PM

  21. sir the ping is also not working

    Comment by Suleman — March 6, 2012 @ 10:08 AM

  22. Hi Sir, Did u remember me?

    Sir actually I have configure Hotspot from MikroTik website. The problem I am having is very slow browsing. Friend of mine told me to use ip address of gateway as primary DNS.

    Is this a good thing. Well, will this help?

    Okay, if I use gateway as Primary DNS. Is it good idea to use opendns along with it, as secondary, thirdly DNS etc?

    Finally, If there is any best suggestion, please let me know.

    Thanks

    Comment by Bablu — March 21, 2012 @ 1:57 PM

  23. Respected Sir,
    1stly i m realy glad and thanks full to you that you are doing a social work in networking field and guiding many of the members without any reward. may ALLAh give you more success and knowldge.
    Sir,
    i am facing a problem with my hotspot. i have configured my network as one server is ISA server for internet distribution and one server is file shareing server on window 2003. with static ip useing 192.168.0.1 series for clients.

    i configured a system as mikrotic hotspot. and then also attach on the same network. with LAN ip as 192.168.2.1. to check hotspot is fine or isa.

    Before attaching mikrotik on the same network. file shareing was working perfectly. but when i have attached mikrotik hotspot on the same network then i m stucked to access my file shareing server by \\server this command.

    is there any troubleshooting sir?

    Comment by Faraz hamza — April 2, 2012 @ 11:47 PM

  24. /ip hotspot set numbers=hotspot1 address-pool=none
    OR
    /ip firewall nat add chain=pre-hotspot dst-address-type=!local hotspot=auth action=accept

    i have applied these two. but still in vain. when i disable address pool to none still its not working. and when i add NAT rule then hotspot login page disapears.

    Comment by Faraz hamza — April 3, 2012 @ 12:06 AM

  25. ok Sir, Thanks a lot for your kind help. i think problem is fixed now.

    Sir i need a suguestion. i m cruntly running an Internet cable i have aproximatly 150 clients. and in peak hour i found 90 Users cruntly do browsing n downloading.
    right now i m running ISA SERVER 2004 (for trafic shaping) with window server 2003. and i have 5 DSL connection 1 is 10 Mbps and other 4 connection are 4 Mbps, and useing TPlink Load balancer to manage all my DSL, in peak our i have not more then 20 mbps load, and i have 6 mbps on backup. after mergeing dsls. but still my Youtube always take buffer after few seconds.

    i want to apply fast browsing. and quick youtube response. kindly suguest me. should i have to move on hotspot to control the trafic? and load balancing with tplink? or the ISA server is the best for internet providing????

    Waiting for your kind reply sir,

    Comment by Faraz hamza — April 3, 2012 @ 2:48 PM

  26. respected brother, im still waiting for your kind suguestion. which one is best for providing internet service in area.(Internet cable).
    Isa server 2004
    or
    Mikrotik

    i want to have fast browsing

    Comment by Faraz hamza — April 4, 2012 @ 4:19 PM

  27. AOA again.

    is There any way to stop the bypassing to hotpot login page?
    Cuz its so easy to bypass hotspot login page.
    if there is any way then kindly guide us.

    thanks

    Comment by Faraz hamza — April 6, 2012 @ 2:38 PM

  28. AOA sir, is it possible if we have configured hostspot server on mikrotik.using 192.168.200.1 series. then we have also a media server on window server 2003 and with ip 192.168.200.2.
    when a new user attach LAN cable then hotspot assign an ip address to client. and he can open easily media shareing by typing \\server. and for internet she have to type username and password.
    is it possible a client wilnot access also the media shareing without login on the hotspot login page?
    for accessing shareing he must have to login 1st?

    Comment by Maria — April 18, 2012 @ 10:48 PM

  29. Thanks Dear 4 ur guidance.. one thing more i want to know.how can we apply also rate limit on Ftp trafic sepratly. like hotspot user getting internet on 1mb speed. and i want to set 7 mb speed for ftp trafic of same users or each ip address comming from hotspot user.?? is there a way to limit them?
    regard
    Maria
    MIT student

    Comment by Maria — April 21, 2012 @ 10:42 AM

  30. Salam…

    i have these records in usermanager router statistics

    Authorization: 17
    Auth failures: 4
    Accounting: 27
    Acct failures: 0
    Disconnect ACK: 0
    Disconnect NAK: 0
    CoA ACK: 0
    CoA NAK: 0
    Broken: 0
    Unknown: 0

    and the radius server has also around 40 accepted requests

    Does this mean that UM is well integrated with mikrotik 750G board (v. 5.12) ???
    if yes why limitations are not taking place either limiting bytes in and out or limiting uptime i tried all kinds of limitation plus users (pppoe & hotspot) are still able to connect without the authorization of UM
    and if not what would be the problem ???
    Thanks in Advance…

    Comment by Mohamad Hassan — May 4, 2012 @ 11:19 AM

  31. what will happen if my client set his ip As static with same range of my DHCP ?
    Does hotspot will redirect him after user enter correct credentials?

    Comment by sal — June 4, 2012 @ 1:55 PM

  32. what is the minimum license level for hotspot setup on a computer system

    Comment by osas — June 15, 2012 @ 5:36 PM

  33. Dear Jehanzaib
    I have 3 interfaces ..1 mikrotik wan / 1 Lan / 3rd one attach with media convertor directly to another net cable services i want to use its shring server over my users..
    Wan = 192.168.15.1/24
    Lan = 172.16.14.1/24
    City = ???

    Comment by Syed Muhammad Kaleem — June 21, 2012 @ 10:52 AM

  34. Aslam-o-Alikum

    sir, i have configured my mikrotik os as hotspot. and i have more then 300 clients.
    i have Set address pool non in hotspot due to FTP trafic problem
    hotspot–>server–>address pool= None

    today i check my address pool used address it wos almost 240 used
    pool–>used address
    there i found one ip for DHCP and one ip for Hotspot is assigned for a single mac address

    and due to this my almost all dhcp address are finished.

    and in future i expect after dhcp address finished new clients will start face problem. so what should i do to start next pool or next series of ip address? and how can i configure it?

    Comment by faraz — June 22, 2012 @ 11:47 PM

  35. Waiting for your reply sir……….

    Comment by faraz — June 25, 2012 @ 12:16 AM

  36. sir ping drop issue araha hai, maine 2mb ki profile banaye hai jab user kuch download kerta haito mikrotik aur dns se ping brake ho rha hai jab profile nhe banata to ping bhe brake nahe hota, please reply

    Comment by Zeeshan — June 28, 2012 @ 6:11 PM

  37. sir ping drop issue resolve nahe hua rb450g v5.18 use ker rha hoon

    Comment by zeeshan — July 2, 2012 @ 8:51 AM

  38. add burst-limit=0 burst-threshold=0 burst-time=0s disabled=no limit-at=1024k max-limit=2048k name=Hi-Prio-to-icmp-”aacable” packet-mark=icmp-pkt parent=global-in priority=1 queue=default

    kya mujhay apna dns name daalna hai aacable hata k ?

    Comment by zeeshan — July 2, 2012 @ 12:32 PM

  39. salam.hello there,currently running a wireless service for my restaurant.
    have few questions,difference between hotspot and wirelesss?
    my wifi network is struggling due to heavy downloading and dhcp pool empty issue,anyway to rectify this .thats it for now.salam.

    Comment by Nazir0 — July 16, 2012 @ 4:12 PM

  40. Dear bro how to secure hotspot server
    any one can cross it or
    match there MAC to any of my active client and use it.
    Any firewall rule to control them ??

    Comment by sami — July 27, 2012 @ 2:19 AM

    • I recommend you to move on to pppoe base authentication, its much more secure from hacking and virus flooding.

      Comment by Syed Jahanzaib / Pinochio~:) — July 27, 2012 @ 6:26 PM

      • Dear Bro,
        Thanks for your Earlier Response ..
        Already using PPPOE service but HOTSPOT: its good looking and m using it for file sharing some other features
        But due to security problems got some problems..
        my friend is also running wisp its open network using hotspot and he challenge me to use there network and i’m unable to break it.. but he didn’t tell me that what he has done ..
        So i recommend to find that security or a firewall..

        Comment by sami — July 27, 2012 @ 7:04 PM

      • Are you using MAC base authentication ???
        Try using USERMAN as radius for your users authentication. This way you will get more control over users authentication + billing.

        Comment by Syed Jahanzaib / Pinochio~:) — July 28, 2012 @ 12:45 PM

  41. Thank you very much brother
    I will try that i hope that i’ll able to find these settings at aacable.wordpredd.com

    Comment by sami — July 28, 2012 @ 1:22 PM

  42. * aacable.wordpress.com

    Comment by sami — July 28, 2012 @ 1:26 PM

  43. Brother i need a help , i am using microtik routerOS and i just want to know one this , that how can i get web log of my users but should be ip, user name or Mac Views
    i have set up proxy server as per ur bolg and i am able to get web proxy cache content , but that is not help full ……………. plz help me out of this

    Thanking

    Comment by Jaffar Saleem — July 31, 2012 @ 4:04 PM

  44. Salaam. Brother which subnet mask should we use with 172.16.0.1 LAN IP /16 or /24 ?

    Thanks

    Comment by nominet — August 1, 2012 @ 2:43 PM

  45. Brother wat with 10.10.10.1/?

    Comment by Sami — August 6, 2012 @ 12:41 AM

  46. Asslam o Alaikum jahzab bhai ma na mikrotik hotspot 5.18 kiya ha 1 problem ha ping kro to net destination unreachable data ha or ping karta b hakbhi yani k 10 mint ping karta ha 10 mint nai karta mgr net theak chalta ha ma na data share karna ha server2003 se jab ping nai karta tu net block ho jata ha plz help me ??????????

    Comment by waqar — August 10, 2012 @ 4:23 AM

  47. dear sir, thanks for the link. really i have tried implementing thee script, but , it didnt work for me. the alert warning comes after i hva been logout by saying u have less than 1ominutes. it will keep on showup. then the other script nothing haappened. pls sir, i will be glad if u can insert the script the right place for me, i mean edit the login page for me for this time alert script. thank sir.

    Comment by emmy smith — August 17, 2012 @ 8:54 PM

  48. Thanks Syed for your response yesterday I will try as you suggested but I have another question: Is it possible to allow free users access only a particular website for a given time period say 1hour daily. I am running hotspot with user manager

    Comment by Timi — August 21, 2012 @ 1:51 AM

    • WEB Proxy will be more useful for http filtering. first redirect only select customer to web proxy, then use web proxy rules to control traffic for them.

      Comment by Syed Jahanzaib / Pinochio~:) — August 22, 2012 @ 9:31 AM

  49. i greet u sir. pls sir, am still waiting for your help with what i told u, before. help me out with the right directions how to get the alert time left for my users. am still new to this. thank you sir.
    emmy smith

    Comment by emmysmith — August 21, 2012 @ 5:27 PM

  50. Thanks Brother for shearing with us. there is a problem which is much major for me. when we use hotspot + pcc load balancing over same server. by default from any website hotspot does not redirect to login page. it needs to open login page manually. if i stop pre routing then it began to redirect can you help?

    Comment by Muhammad Arslan — August 21, 2012 @ 9:38 PM

      • hi syed am a small isp in bangalore i learned mikrotik from your blog only….now i need your help to configure let me tell u my setup first i have a mikrotik config as follow

        eth1 WAN/eth2 LAN/eth3 http file server/ i have configured pppoe and hotspot on eth2 and its working fine but challenge is i want people to use my http file server with out any speed limit after logging in but i couldnt do it .speed remains same as the internet speed. please please help me do it.

        Comment by arun kumar — August 24, 2012 @ 7:13 PM

  51. Many Thanks Syed, the load balancing seems to be working and my next project will be building a Squid server “I noticed you have instructions on adding and redirecting Squid to Mikrotik but do you have a step by step instruction on the Squid setup?

    another question:
    Is it possible to allow free users access one or two website only for a given time period say 1hour daily.

    Regards

    Comment by Timi — August 22, 2012 @ 9:22 AM

  52. sir rb250g having big problem with hotspot please help me. users complaining about mikrotik login page appears 100′s of times. but i didn’t set any kind of time limit please help me. i will send you a backup if you need it. please please help me i am stuck badly.

    Comment by Zeeshan — August 25, 2012 @ 9:34 AM

  53. sir rb450g having big problem with hotspot please help me. users complaining about mikrotik login page appears 100′s of times a day. but i didn’t set any kind of time limit please help me. i will send you a backup if you need it. please please help me i am stuck badly.

    Comment by Zeeshan — August 25, 2012 @ 9:36 AM

  54. Dear Sir,

    Thanks for the guide u gave me is ok. now. but i have problem. well when i login with my credit unit, and later logoff, when i comes back to use the same credits left, i will release that am left with nothing , the whole unit has finished. i dont know why , can u pls sir help me out with is. is like the credit is still running , while u have logoff. help me out. thank u. emmysmith

    Comment by emmy smith — August 29, 2012 @ 5:08 PM

  55. Dear Sir,

    Thanks you very much for you tutorials, I have problem with my mikrotik din not remembered the user log in. Every time we connect it again, it comes the page to put user name & password again and again. Any problem? and i want to put “Remember Me” on login page, How?

    Best regards,

    Comment by SNPK — August 30, 2012 @ 6:27 AM

  56. Hi
    thank you for your useful articles.
    I followed the steps and ran the PPPOE server with UM.
    two problems still exist:
    1.before i connect with PPPOE I cannot use my LAN resources!! after I make the connection I can use them but with low speed which I have defined for the internet in UM limitations.
    2.I can see Hotspot login page but when I enter username and password nothing happen.!!
    could you please help me .
    thank you again

    Comment by Javad — September 14, 2012 @ 11:32 PM

    • are you running hotspot with pppoe on same server? which version u r using ?

      Comment by Syed Jahanzaib / Pinochio~:) — September 16, 2012 @ 1:00 PM

      • assalam o alikum Syed Jahanzaib bhai … plzz tell me ur cell phone no or email address mari mikrotik device mn kuch problems a rahay hn ap say discuss karnay hn plz plz plzzz reply soon

        Comment by Umair — September 21, 2012 @ 11:42 PM

  57. assalam o alikum Syed Jahanzaib bhai … plzz tell me ur cell phone no or email address mari mikrotik device mn kuch problems a rahay hn ap say discuss karnay hn plz plz plzzz reply

    Comment by Umair — September 21, 2012 @ 11:42 PM

  58. users can log in on my hotspot bt ar nt able to access d internet, error message is web page nt available. without hotspot they can access d internet. pls wat culd d problem be. it was workin perfectly before naw.

    Comment by seun — September 29, 2012 @ 2:34 AM

  59. dear sir how i byepass the mikrotic hotspot logen page .if there is a easy way to byepass please tell me

    Comment by Akhtar — October 1, 2012 @ 11:47 AM

    • You mean you want to turn off authentication for specific user? so he can browse internet without any login page appearing.
      you can use bypass mac address feature.

      Comment by Syed Jahanzaib / Pinochio~:) — October 5, 2012 @ 8:36 AM

  60. Hello, I have a special request about day and night usage. I followed the link : http://wiki.mikrotik.com/wiki/Different_bandwidth_in_day_and_night_for_several_categories_of_users
    on my hotspot I am unable to figure out how to apply the instructions to my users.

    Kindly share your experience with me.
    Regards

    Comment by Taha — October 5, 2012 @ 3:28 AM

  61. Dear site manager,
    i configured my Mikrotik as hotspot and work properly, but my customer wants to create a schedule of time for his users.
    my “user1″ can connect to hotspot from 08AM to 12AM on specific day of week.
    please tell me can i configure RB-750 device to handle this.
    Best regards

    Comment by Mostafa — October 26, 2012 @ 1:51 AM

  62. nice Work

    Comment by matloobfsd1 — November 2, 2012 @ 5:00 PM

  63. Dear Sir mikrotik routerboard load balancing rb750 setting setup please reply me
    2Wan 1Lan

    Comment by matloobfsd1 — November 2, 2012 @ 5:04 PM

  64. Sir i am new to mikrotek platform i have configured hotspot server but i want to limit bandwidth of my user so how can i do as you mentioned above i have different ip scheme working kindly let me know what to do AS THE SETTING YOU MENTIONED IT DOES NOT WORK GIVE ERROR EVERY TIME

    Comment by ZAIN — November 8, 2012 @ 8:23 PM

  65. sir main ne pcc load balancing ki hai lekin masla yeh hai jab main dono line lagata hon to logan page nai ata jab k single line lago to login page ata hai main hot spot use kar raho hon

    Comment by rana shahid nadeem — November 23, 2012 @ 4:41 PM

  66. Dear Sir Mikrotik Groovr a2hn ka setup please replay kar dy video main kar dy tu zyda acha ho ga thanks

    Comment by rana shahid nadeem — November 23, 2012 @ 4:45 PM

  67. dear sir sceripts past karny k tarqa kia ha
    sceripts end per save to nahi hota kia

    plz replay

    Comment by rana shahid nadeem — November 26, 2012 @ 4:46 PM

  68. SIr agar ap ko bura na lagaya tou main yeh kehna cahuon ga keh mujhe itna computer nhi ata agar ap mujhe mere email par koi achi speed ka login aur password bta dey th bohat acha hojaye ga merey liye e mail anasasghar@hotmail.com

    Comment by Anas Asghar — November 27, 2012 @ 7:51 PM

    • Dear sending script would do no good to you You have to first learn basis of the mikrotik that how it works at a basic surface level. Read the Mikrotik Wiki / Forum, they are very helpful. If you directly wanna jump to advance level, no one will help you.

      Comment by Syed Jahanzaib / Pinochio~:) — November 28, 2012 @ 10:24 AM

  69. Assalamualikum IP/User then when logged in customer is able to to switch profile thorugh status how to disbla option

    Comment by abdul hameed — December 21, 2012 @ 9:48 AM

  70. Hi, Sir
    How can I configure my router in such a way that, – if there is any changes in the router configuration – then it should send mail to particular person.

    Thanks In Advance
    Kishore

    Comment by Kishore — December 27, 2012 @ 9:59 PM

  71. dear brother main hotspot server use kar raha ho mere kuch clint ko loging nahi karna ata ha plz aap mujey thoro sa tafseel k sath bta dy k un users ko kise manaje karo thanks

    plz reply

    and jashen e melad mubrak ho aap ko

    Comment by Shahid nadeem — January 16, 2013 @ 11:13 PM

  72. aslam o alakum
    sir mn hostpot man mac address ki restriction man 1 ki gaja par 2 mac address likhna chahta hon kia posibal ha? agar ha to kasay

    Comment by m.irfan — January 26, 2013 @ 7:35 PM

  73. thanks sir

    i have problem with user traffic limit in v6
    i make pakage with 50 mb traffic its ok. but jost user disconnected from internet and redirect to login page and if he use same user and password users can be use same traffic as well ” in other way traffic counter reset after user log out from server”

    plz help me

    i just to have data limit no time limit

    thanks

    Comment by meisam pordel — January 29, 2013 @ 12:37 AM

  74. Assalamol-e-Kom
    Dear Mr.Jahanzaib

    Your forum is very helpful and i realy apreciate ..

    I have a question about Mac Address.There is any way to block all mac address except allow list

    Comment by Qasim Siddiq — January 29, 2013 @ 4:00 PM

    • Yes you can create list for allowed mac address. Make allow rule for this list, and then create second rule which denies all traffic from internal clients. rules are processed order wise.

      Comment by Syed Jahanzaib / Pinochio~:) — January 30, 2013 @ 4:16 PM

      • hello sir,

        last few days i am tired to writing a wants on forum but no replay or answer getting from any body. can you please help me , you are expert so. i am not expert enough on mikrotik router.

        i have a router RB450G, i have successfully setup hotspot and its working good. my problem is i want to block facebook for some hotspot user account. i have around 70 computer on my office. when i login from any computer i can get access of internet which i wants mainly.

        now i want to block some website like facebook for some hotspot user. how can i configure this ? not with IP, using Layer 7 specific IP block working but i want to make it hotspot user based. if somebody have facebook access he will get access even he sit any computer. other way someone who donot have facebook access, even he sit any computer and use his login, he will not get facebook access.

        does it possible ?

        i am sorry to disturb you again, but if you can help me with this, it will be very easy for me. i have tried many link through google, but i failed , so please help me.

        Comment by Riajul Islam — February 22, 2013 @ 1:21 AM

  75. [...] Sorce Link click here [...]

    Pingback by Mikrotik hotspot setup | Gkhan Tips — January 30, 2013 @ 11:20 PM

  76. /ip firewall nat add action=masquerade chain=srcnat disabled=no

    What is this command for?
    it is blocking userman
    if I disable it user man will work but clients will not be able to browse

    Comment by Alex — January 31, 2013 @ 6:18 AM

  77. i have mikrotik rb750gl. port1 wan & port2 hotspot lan user. when i want hotspot login page access, don’t open login page. cause antivirus block login page. it is not open. i disable antivirus than open login page. pls help me………….

    Comment by aman — February 5, 2013 @ 12:41 PM

  78. how to redirect HTTPS urls to my hotspot login page and also in WEB PROXY ACCESS page redirection.
    any script for tutorial please guide us here and in your website
    thankyou…!

    Comment by hammad hassan — February 8, 2013 @ 11:14 AM

  79. ASAK Syed,

    I am new in Mikrotik product line. I am trying to make a hotspot in the vehicle using 3G data card with RB411U routerboard. Appreciate if you can tell me how to setup or point me to a right direction. I can surf the internet on my laptop when my laptop is directly connected to RB411U board. I am trying to make a hotspot as soon the car start. Also is there anyway I can by pass logging page so user can go on the internet without logging in. Please advise. Thanks Amin

    Comment by Amin Ansari — February 11, 2013 @ 7:13 AM

    • To make the hotspot start as soon as the hottpot start i think there will be no problems with that because you just need to connect the RB to the main electric connection which already setup with hotspot configuration. To bypass loggin you can search in wiki mikrotik or mikrotik forum because it will just need to uncheck the user with macaddress that you need to use the hotspot without login.

      Comment by Djemmy — February 15, 2013 @ 2:15 PM

      • sorry i meant the hotspot start as soon as the car start…

        Comment by Djemmy — February 15, 2013 @ 2:16 PM

  80. Syed, have you ever make an hotspot with free trial but you want to disable the free trial user for some computer ?

    Comment by Djemmy — February 15, 2013 @ 2:09 PM

  81. sir AoA,
    How can i change hot spot error message like Session profile not veiled to Account is Expired .like this

    Comment by Ali — February 22, 2013 @ 11:44 PM

  82. Uff……………………………..Himat hai bahi apki:p:p:p Umeed hai samjh gaye hongay:p:p:p……….Jannat mein mujhe bhi pehchan li jiega plzzzzzzzzzzzzzzzzz

    Comment by Shery — February 25, 2013 @ 11:58 PM

  83. How can i change hot spot error message like Session profile not veiled to Account is Expired .like this

    Comment by Ali — February 26, 2013 @ 6:58 PM

  84. hello, i need your help on mikrotik server 2347032818686,

    Comment by kayode — February 28, 2013 @ 11:54 PM

  85. Hello Dear Syed Jahanzaib ,

    First of all I need to say thank you for your hard work it’s really so hard to be creative and organized like you . not all ITs like to share and give like you .
    I have some questions and hope you can help me .
    1- did you ever try kerio control , if so what do you think about it could it be a big alternative to mokrotik

    2- I have a network with 60 users using mikrotik 2.9.27 on old pc intel pantuim 4 2.4 speed and 1 g ram and it start to be so slow should i upgrade my pc .

    3- Could you please help me , here is what is going on my country I ‘m from Egypt , now a days Internet companies is sucking us really , highest speed is 8 mb and at 12 pm it start to be 4 mb . How to make a good network that can handel 3 lines 8+8+8 and make an internal web server ( ubuntu , windows server 2003 , or xammp on xp ) need this server to be so fast as much as nic speed . an internal mail server , Ftp Server , media broadcast server . do not know if should have DC or not .

    4- I am confused between ” Isa Cache , squid , smoothwall cache”

    can you help me in this . what hardware should i use for servers , how to connect all servers and make go to users with their NIC speed and how it will look like ?

    Thank you

    Comment by M — March 3, 2013 @ 6:06 AM

    • 1- I have never tried KERIO, I am sure it would be good, every product is good in its own domain.
      I have worked with Mikrotik and found it more suitable, most advance and customizable product with great compatibility and stability. All in all, Mikrotik is great choice for about every sized network.

      2- Yes you should upgrade your PC. However Mikrotik dont required higher hardware untill or unless your network is very crowded or you have lots of firewall/queue and other rules in place.

      3- Yes you can introduce many new service son your network, also you can combine multiple WAN links connection to get more speed using Mikrotik PCC technology. for extra services details, please email me and i will reply in detail.

      4- ISA , Squid are Cache servers,
      The simple one is ISA,
      but with Mirkotik SQuid performs well.

      5- Gotto go , reply you later

      Comment by Syed Jahanzaib / Pinochio~:) — March 3, 2013 @ 11:50 PM

  86. sir maine user profile banaya hai …. us main DNS ki entry bhi sahi di hai per hotspot ka login page nahi aata .. per browser per direct ip lagata hon tu aajata hai .. aur doosra problem yeh k default speed per user chal raha hai … per jab 1 mb ya 2 mb ..ki speed user ko deta hon tu page hi nai khulta …. plz solve my prblem …

    Comment by M.Ali — March 3, 2013 @ 7:08 PM

    • If you can open hotspot page via IP, then for sure its the DNS related issue.
      # Make sure client have primary DNS pointing to your hotspot server ip.
      # Make sure you have static DNS entry in Hotspot DNS server, double check it on DNS section of Mikrotik
      # From client side, open command prompt and type nslookup and enter. then type your hotspot server dns name, (name which is entered in dns section) it should return its ip , if not, then your mikroitk dns is not responding to client request. troubleshoot it.

      Comment by Syed Jahanzaib / Pinochio~:) — March 4, 2013 @ 9:51 AM

  87. Wow , SO Fast , Thank you a lot , Take your time I will Wait .

    Comment by M — March 4, 2013 @ 12:57 AM

  88. Yeah I know little bit about ppc , I’m sorry can’t find your Contact page and email Here .

    Comment by M — March 4, 2013 @ 1:15 AM

    • aacable @ hotmail . com

      Comment by Syed Jahanzaib / Pinochio~:) — March 4, 2013 @ 9:48 AM

      • brother ap k dono side clips or server(isa) pa ipa same hone chaheya yani k agr ap ki sharing ko isa se ip assign hwa ha tu ap k client ko b isa se hna chaeya agr ap k client ko mikrotik se hwa ha tu sharing ko b mikrotik se hna chaheya ap mikrotik ki dhcp off kar do sub ok ho jaye ga

        Comment by waqar — March 6, 2013 @ 3:30 PM

  89. respected sir, i m faceing file shareing problem kindly suguest me any trouble shoting. here is my diagrame

    Server 1 = ISA server 2006 (window server 2003) Ip=192.168.0.1 (DHCP=off) (DNS=on)
    Server 2 = File shareing (window server 2003) LAN1 IP=192.168.0.2 (DHCP=off)
    LAN2 ip = 192.168.0.2

    i was useing the above 2 servers 1 for net and other for shareing since 2 years.
    Clients configure there computer by giving menualy a static ip address.
    i didnt get any problem. now i have added server 3 on the same network just to test its performance.

    Server 3 = Mikrotik os (using Hotspot)
    configure as:
    LAN=For clients
    WAN=for Internet using mikrotik load balancer
    addresses list
    LAN ip = 192.168.2.1
    Wan ip = 192.168.11.1
    DNS configured
    DHCP configured

    then i setup hotspot

    everything is working fine. mikrotik working fine. its DHCP properly assigning ip address. and hotspot login worked and internet working fine.

    Just faceing an isue with my file shareing. after adding this mikrotik os on my network. my existing clients are faceing isue when they try to open file sharing by putting \\server name and sometime it open but after few time it again disapear.

    when i remove mikrotik os server. then network again work fine. without any problem.

    Can i know why after adding this mikrotik i m getting isue with my fileshareing system??
    is there any trouble shooting.??

    Regard

    Comment by shahram nilieh — March 4, 2013 @ 2:39 PM

    • brother ap k dono side clips or server(isa) pa ipa same hone chaheya yani k agr ap ki sharing ko isa se ip assign hwa ha tu ap k client ko b isa se hna chaeya agr ap k client ko mikrotik se hwa ha tu sharing ko b mikrotik se hna chaheya ap mikrotik ki dhcp off kar do sub ok ho jaye ga

      Comment by waqar — March 6, 2013 @ 3:30 PM

  90. I’ve emailed you .

    Comment by M — March 4, 2013 @ 5:25 PM

  91. Asslam o alaikum sir ma na rb 750 ki loadbalancing kar k 2mb 4 mb or 4m use kar raha ho or phr 5.18 os pppoe ha ha problem ya ha k dafult ki speed pa b skype k signal white nai hoty wo yahi kahta ha k slow speed or youtube buffering karty ha bht zyada ………..koi b soltion hi zarror batayan agr mikrotik se koi bhtr ha jo ya problem solve kar da i use it bt tell me plz

    Comment by waqar — March 4, 2013 @ 8:52 PM

  92. sir … i have lan ip .gateway is..192.168.0.1 … and my Primary dns is 8.8.8.8 and secondary 8.8.4.4 … i have 8 mb and 4 mb connection with loadbalancing ….my static dns ip is 192.168.0.1 …… but still my page of server profile is not coming, jab tak browser per ip na doon .. and user profile is not working 2 MB even 4 MB …

    Comment by M.Ali — March 4, 2013 @ 10:49 PM

  93. ASAK does anyone know if RB411U or any other Mikrotik board support two simultaneous embedded cellular carriers? I saw one carrier card slot, but wasn’t sure if two was available. Thanks Amin

    Comment by Amin Ansari — March 5, 2013 @ 1:33 AM

  94. hello sir how to i set the ttl setings ? In Mikrotik Routerboard 750?

    Comment by Mahendra Harijan — March 5, 2013 @ 10:34 AM

  95. how I can set shared users to share bandwidth.

    When 2 users are logged on the hotspot with the same username, they each get the bandwidth specified in user-manager.

    How can this be changes so that if 2 users are logged in the bandwidth will be 50% to A and 50% to B

    and if 3 users each on gets 33.333333% of the alloted bandwidth

    hope there is a solution for this.

    Comment by Owais Malik — March 9, 2013 @ 1:49 PM

    • Use PCQ method to distribute bandwidth among shared users who uses same ID for login. Use specific Pool for the shared users who will share bandwidth from defined pool.

      Comment by Syed Jahanzaib / Pinochio~:) — March 10, 2013 @ 7:09 PM

  96. hi sir i m Anwar sultan and i need con fuger my mikrotik kia ap apna no day sakty ha r sms me you number i l cal u 03455961029 thanks

    Comment by Anwar Sultan — March 30, 2013 @ 9:45 PM

  97. how to redirect HTTPS urls to my hotspot login page and also in WEB PROXY ACCESS page redirection.
    any script for tutorial please guide us here and in your website
    thankyou…!

    Comment by houlibi — April 23, 2013 @ 8:43 PM

  98. sir, how to block facebook and other desired websites for hotspot interface only and not for other interfaces??
    e.g. My hotspot interface is in ether2 and Wan is in Ether1. I have setup webproxy but it works for all interfaces.Please help.

    Comment by Sam — May 20, 2013 @ 12:20 PM

  99. Hi, does anybody knows how to set “quota reached ” instead of “threshold reached” described on Appendix A.1 page 69 in the draft-lior-radius-prepaid-extensions-22.txt?
    I have a mikrotick x86 v5.24
    Regards

    Comment by Enrique — May 23, 2013 @ 9:41 PM

  100. hello sir,

    main pc mein hotspot with redius banaya h.. sub kuch thik chal rha h, but kuch prob hai. agr aap help ker skte ho to plz help me..

    1. jab bhi customr download lagata hai to uski ping drop hoti h,,,,,
    2. customer ka time chnage kse hoga..ex, user 05/06//2013 ko bnya tha.. wo runing mein h… ager mein iska time 15/06/2013 krna chahata hu to user manager main kse change hoga…(05/06/2013 to 04/07/2013 it change into 15/06/2013 to 14/07/2013)
    3. user manager customer logs ko kse save kr skte h.. i use 500GB hdd in computer
    4. ager hotspot se related kuch or knowladge mile jaye wo bhi thik ho,

    Comment by bunty — June 19, 2013 @ 11:06 AM

    • 1- Queue also limits ICMP packets i.e ping , You will see high ping delay if you are using downloading/surfing at full bandwidth capacity. to bypass ICMP from the queue, try this > http://aacable.wordpress.com/2011/12/07/mikrotik-howto-give-ping-icmp-high-priority/

      2- You can’t lessen the few / single user expiry date without moving the data back/forward which will also effect over all the users.

      3- User Manager logs saves in userman DB.

      4- What specific knowledge regarding hotspot you need? Visit Mikrotik WIKI and forum, they are the best source of knowledge

      Comment by Syed Jahanzaib / Pinochio~:) — June 20, 2013 @ 12:52 PM

    • sir,

      maine Mikrotik PiNG / iCMP high Priority wali command add kar ke dekh liya h.. fir bhi ping loss ho rha hai…

      i hav use 5.20 in a computer…
      thank for rply

      Comment by bunty — June 28, 2013 @ 9:42 PM

      • Do you have other Queues / Dynamic Queues in place?

        Comment by Syed Jahanzaib / Pinochio~:) — July 1, 2013 @ 9:37 AM

      • no sir, i hV NOT any queuss in place..
        simlpy i hav install 5.20 in a p4 computer. run hotspot.. and redius
        whan i hav download any file via internet then local & dns & yahoo, gmail ping gose to very high and losess..as like
        time ttl=1024ms,
        time ttl=2104ms,
        request time out

        i want like that when coustomr donloa any file when ping rply normaly as like
        time ttl=2ms
        time ttl=3ms
        time ttl-2ms
        time ttl=4ms

        if you hav any way of isttaltion or hotspot setup .. or other opption for bandwirth management system
        so pls tell me as well as posible..
        bcz i m waiting for this problem solution.. after that i hav insttal my server

        Comment by bunty — July 1, 2013 @ 11:31 PM

      • what ROS you have in place? maybe we can do remote session to test the issue,

        Comment by Syed Jahanzaib / Pinochio~:) — July 2, 2013 @ 9:15 AM

      • i hav use mikrotik x86 5.20 os..
        and my pc confrigation p4 3.06, ram 2gb & HDD 500GB,

        Comment by bunty — July 2, 2013 @ 8:30 PM

      • Dear syed,,

        finaly I told u me prob with hotspot

        I hav using SWOS 5.20 in a computer,
        I hav setup hotspot with redius. everything is ok. but some prob are disturb me.

        1. jab koi user online hota h to uski ping ok hoti h.. but jb user download lagata h to ping losse hoti h..

        ex. ping 192.168.1.1 -t
        jb download krte h to ping losses hoti h……….

        2.jb user download lagata hai to uski browsing speed se nhi hota h.. http://www.google.com bhi nhi khulta h….

        plz help

        Comment by bunty — July 15, 2013 @ 2:21 PM

      • This is normal behavior that ping looses or delay increases when user starts downloading, because ICMP is also restricted by the queue created by the router for the user.
        read this.
        http://aacable.wordpress.com/2011/12/07/mikrotik-howto-give-ping-icmp-high-priority/

        To give more preference to browsing, you have to use custom base queues, please read teh forum there are lot of examples in this regard.

        Comment by Syed Jahanzaib / Pinochio~:) — July 16, 2013 @ 8:20 AM

  101. Asslam o Alaikum..ak masla hy …plz help me.vo ye k hotspot speed profile to sahi ban gai hy..har user ko speed b meri marzi k mutabik jati hy …..pr jub mein kisi ka mac ip binding mein dalta hu to jub vp speed test karta hy to sari ki sarti speed usy chali jati hy ..kya mein us user ko apni marzi k mutabik speed day sakta hu jis ko ip binding mein add kea hoo…………..plz help mee… or agar ho sakay to plz tafseel say bata dena thnks..me waiting your answer

    Comment by Rashid Butt — June 26, 2013 @ 7:16 PM

    • Dynamic queue donot create automatically for bypassed mac users. You have to create static queue for specific IP’s or Pool.

      Comment by Syed Jahanzaib / Pinochio~:) — June 27, 2013 @ 3:40 PM

  102. please bro am using routeros for hotspot services and i have customised my hotspot login page when ecer i try logging in i get this error “unable to send challenge response(restart browser or enable java)” but i have java enabled already.

    Comment by desire — June 30, 2013 @ 7:44 PM

  103. I am using the Mikrotik , It has configured with HOTspot with My radius server, I am using the coupon(UN/PW-which was created in my radius server) for logging in & i am able to login also after some time again login page is coming & ask me login again how to stop this? If once it’s loggedin means it should valid up to the time ends(plan end- for example if 30 min coupon means upto 30 min he shouldn’t get login page). How to set this?

    Comment by Nirmal — July 1, 2013 @ 12:10 PM

  104. what is the possible problem is you are getting Radius not responding. I have radius + usermanager in one box

    Comment by Alvin — July 16, 2013 @ 11:37 AM

    • Make sure secrets are same in Userman+Radius Section.
      Whats teh timeout value you have set there?

      Comment by Syed Jahanzaib / Pinochio~:) — July 16, 2013 @ 1:33 PM

      • the secret password is the same. i already tried different timeout values. still i get the same problem.

        Comment by Alvin — July 21, 2013 @ 5:59 PM

      • email me and maybe we can have team.v session

        Comment by Syed Jahanzaib / Pinochio~:) — July 22, 2013 @ 8:48 AM

  105. 105. Can anyone assist with a web logon issue. When using an iPad or android phone i am unable to click on the logon option and type my details. As soon as i click on the username option it points me to my ISP page. It just wont let me click on username and let me add details. If i use a PC it works fine. Help please…

    Comment by Paulvb — July 24, 2013 @ 4:04 PM

  106. Sir, It is surprised i confugered the mikrotik hotspot and see the wan port is uploading 2 mbps bandwidthh and all lan are free and idle mode even if removes the lan cable still it uploads. i tried many time resetting the same but no result found. how it happns??

    Comment by Abidali — July 25, 2013 @ 2:22 AM

    • disconnect the LAN cable from your hotspot. and then check.
      is there proxy also setup in your box?
      it could be dueto dns too.
      make sure you block all the un.used services like ssh/ftp etc.
      also make your router in LOCKDOWN mode, by blocking ALL INPUT traffic at WAN interface and allow specific traffic to enter via your WAN interface.

      Comment by Syed Jahanzaib / Pinochio~:) — July 25, 2013 @ 7:56 AM

    • Good day Sir

      I am still not sure as too how I can resolve the issue of my clients Ipads and Android phones that cant connect to the internet. When we click on the username it takes us to our webpage and does not allow us to logon. Can you assist us with please.

      Kind Regards

      Paul van Blerk

      Tel : +27 11 795 0900

      Cell: +27 82 873 6097

      Fax to Mail: +27 86 710 9654

      E-mail : paul@netcon.co.za

      Web Address : http://www.netcon.co.za

      Netconnect Logo (round)

      Level 5 B-BBEE Contributor

      From: Syed Jahanzaib Personnel Blog to Share Knowledge ! [mailto:comment-reply@wordpress.com] Sent: 24 July 2013 11:23 PM To: Paul van Blerk Subject: [New comment] Mikrotik Hotspot Quick Setup Guide + Tips n Tricks for Hotspot !

      Abidali commented: “Sir, It is surprised i confugered the mikrotik hotspot and see the wan port is uploading 2 mbps bandwidthh and all lan are free and idle mode even if removes the lan cable still it uploads. i tried many time resetting the same but no result found. how it “

      Comment by Paul van Blerk — July 25, 2013 @ 11:14 PM

  107. hi its aoczon@gmail.com i also sent you pm on fb thanks

    Comment by Alvin — July 27, 2013 @ 1:07 PM

  108. Thaks for article,,this is article the best for learning about mikrotik

    Comment by dermon s — August 8, 2013 @ 2:30 PM

  109. 109. Can anyone assist with a web logon issue. When using an iPad or android phone i am unable to click on the logon option and type my details. As soon as i click on the username option it points me to my ISP page which i have allowed for users who dont have an account. It just wont let me click on username and let me add details. If i use a PC it works fine. Help please…

    Comment by Paulvb — August 13, 2013 @ 11:52 AM

  110. Dear sir, This is Fahim from Bangladesh. I have a question. My question is -How can i setup hotspot without DHCP ? actually i want to provide my users static ip address.
    Is it possible.?

    Comment by Fahim Mahamud — September 7, 2013 @ 12:22 AM

    • just assign static ip at user end, make sure its of same subnet as hotspot. and make sure you add default gateway and primary dns pointing to mikrotik hotspot lan ip.

      Comment by Syed Jahanzaib / Pinochio~:) — September 7, 2013 @ 10:37 PM

  111. Respected Sir

    In hotspot segment some users need without authendication. as you told it is possible with ip binding option. but how can we control bandwith and logs for non authencation users. is userman do this job.
    thanking you
    Regards
    saravanan
    wifiworld communications

    Comment by saravanan — September 28, 2013 @ 9:00 AM

  112. Dear Sir,

    I would like the users (auth or unauth) in my network to be able to access my walled garden IP’s without NAT (actual user IP), the private IP subnet of my users and my walled garden are routable (this was tested before adding the snat statement) once i add the SNAT in the NAT section all the requests from the users are being natted for my walled garden…please suggest to resolve this

    Comment by Madz KEYN — September 28, 2013 @ 10:13 PM

  113. can i monitor client broser activity via Mikrotik hotspot?

    Comment by xaindero — October 1, 2013 @ 2:09 AM

    • Only if you enable web proxy, then you can view http logs, but its practically hard to monitor them.
      its better to enable web proxy and send its log to remote log server.

      Comment by Syed Jahanzaib / Pinochio~:) — October 1, 2013 @ 10:24 AM

  114. Hello Syed, I need your help. I have a profile for all weekend and night only internet access on usermanager, that works just fine but I need that profile to have a total data transfer limit of say 5.5Gb. My problem is that the profile has three rules to make it work: rule 1: 7pm – 11.59pm (mondays – fridays) rule 2: 00:00am – 6.59am (mondays – fridays) and rule 3: 00:00am – 23:59pm (saturday & Sunday) now where will I have the transfer limitation inserted. For If I have 5.5G on each rule it looks like my user will have a total of 16.5G.

    Comment by Timi Green — October 15, 2013 @ 11:43 AM

  115. thanks

    Comment by ip man — October 30, 2013 @ 7:55 AM

  116. Hi Sir,

    I have three isp
    1. directly maintain by the isp second whose ip is 172.16.0.0/255.255.255.128 with mikrotik 1100ahx and we dont have any access to change anything whose default gateway is 172.16.0.1.
    2. second is on ppoe connection, using mikrotik 750gl with gateway 172.16.2.2/255.255.255.192
    3. third is on static ip which is not public but they have locked my mac address logged in another 750gl giving gateway 172.16.2.10/255.255.255.0

    all of them gets connected to a cisco unmanagable 24 port switch.

    now when i created a hot spot as your instructions i was successfully able to create it but the ip range 172.16.0.0 is also getting a login page however i have just configured on 172.16.2.0 with only first 750 gl with gateway 172.16.2.2,

    we have configure all the user with static ip instead of dhcp. still load of another subnetting are getting NAT and starts using the ip which is in the ip pool.

    can you please help me how can we overcome this problem…

    thank you in advance.

    REGARDS,
    KRUNAL DESAI

    Comment by krunal desai — November 9, 2013 @ 6:07 PM

  117. Sir,

    Have you tried to configure the Mikrotik with 2 hotspot servers?
    My objective is to have a different login page in my two clients.

    Thanks,
    Ladz

    Comment by Ladz — December 6, 2013 @ 6:54 PM

  118. Hi,
    How can I add prefix (3 characters) to username after submitting login.html page in hotspot?
    My all radius users have common first 3 characters (prefixed).
    With regards,
    Inder

    Comment by Inder — December 12, 2013 @ 6:51 PM

  119. ASALAM-O-ALIKUM,
    I have been using hotspot and userman for a couple of years, I would like to know how I can set shared users to share bandwidth.

    When 2 users are logged on the hotspot with the same username, they each get the bandwidth specified in user-manager.

    How can this be changes so that if 2 users are logged in the bandwidth will be 50% to A and 50% to B

    Comment by Owais Malik — December 13, 2013 @ 9:33 AM

  120. can we redirect user to diffrent page based their user profile ? exm profile1 will redirect to aaa.com and profile2 will redirect to bbb.com after they login to hotspot

    Comment by kidx13 — January 9, 2014 @ 11:43 AM

  121. sir kia ap muje bata sakete hen k pc main loadbalcing kese hongi. mikrotik main.. plz sir i realy need it

    Comment by Rehan — March 5, 2014 @ 8:28 PM

    • The process is same , either in Routerboard or PC base mikrotik as the OS is same on both.
      Just add required LAN cards in it and do the config as you do in RB.

      Comment by Syed Jahanzaib / Pinochio~:) — March 6, 2014 @ 8:48 AM

  122. Hello Sir,
    I have Microtik board 450g. i had already created a hotspot and i have three profile (i.e. profile1, profile2, profile3) . in that same hotspot i want time limit access in profile1. and other profile want to access internet any time. it that possible ?

    Comment by Dinesh Shrestha — March 21, 2014 @ 4:12 PM

  123. AOA
    sir i am using hfs server for local sharing.i want to redirect user after login to my hfs page. i have modified value=$(link-orig) as value=http://172.16.1.249:81.
    when the user login , they does not redirect to my hfs page. what should i do now ?

    Comment by knil — March 29, 2014 @ 11:55 AM

  124. sir i created user profile of 1mb but some time client are getting more then their profile.i am using rb750gl. from last 1 year it was woking fine but now this starts to happen. can u guide ne. thank adnan

    Comment by adnan — April 3, 2014 @ 4:46 PM

  125. aoa to all i m new in wifi networking i dont have much knowledge about Mikrotic RB 750 but i have this device i want to use it and learn about it plz help me
    M Waleed Ahmad 03216765152

    Comment by waleed — April 9, 2014 @ 11:47 PM


RSS feed for comments on this post. TrackBack URI

Leave a Reply

Fill in your details below or click an icon to log in:

WordPress.com Logo

You are commenting using your WordPress.com account. Log Out / Change )

Twitter picture

You are commenting using your Twitter account. Log Out / Change )

Facebook photo

You are commenting using your Facebook account. Log Out / Change )

Google+ photo

You are commenting using your Google+ account. Log Out / Change )

Connecting to %s

The Silver is the New Black Theme Blog at WordPress.com.

Follow

Get every new post delivered to your Inbox.

Join 2,043 other followers

%d bloggers like this: