Syed Jahanzaib – Personal Blog to Share Knowledge !

September 27, 2011

Howto create Windows 7 PPPoE Dialer Installer Package using Auto-iT !


PPPoE Dialer Package Sample

THIS IS SOME OLD CODE AND MAY NOT WORK PROPERLY NOW. KINDLY LOOK FOR SOME OTHER SOLUTION. JUST READ IT FOR INFORMATION PURPOSE ONLY BUT IT WILL NOT SERVE ANY GOOD TO YOU I GUESS

THIS IS SOME OLD CODE AND MAY NOT WORK PROPERLY NOW. KINDLY LOOK FOR SOME OTHER SOLUTION. JUST READ IT FOR INFORMATION PURPOSE ONLY BUT IT WILL NOT SERVE ANY GOOD TO YOU I GUESS

THIS IS SOME OLD CODE AND MAY NOT WORK PROPERLY NOW. KINDLY LOOK FOR SOME OTHER SOLUTION. JUST READ IT FOR INFORMATION PURPOSE ONLY BUT IT WILL NOT SERVE ANY GOOD TO YOU I GUESS

 

Following is a guide on howto to create Windows 7 PPPoE DIALER Installer Package.  It is based on same principles as my previous Winxp PPPoE Dialer Script.

Being a Linux Lover, I am publishing these codes under GPL (General Public License). You can modify it as per your requirements, redistribute it. Don’t forget to give credit if it helps you :~) Remember it’s not a standard, neat and clean way but It’s very simple and it do the job nicely:)

This script is made for Windows 7 Operating System Only, For windows XP/200x, please follow the below link.
https://aacable.wordpress.com/2011/09/01/howto-create-pppoe-dialer-installer-package-using-auto-it/

Following functions will be performed.

# First it will ask you if you want to continue to install the Dialer.
# Then it will minimize all opened Window to Let user focus the installation,
# Then it will show you the Logo in front(dialer.jpg which is customizable according to your need),
# in Background it will open the Network and sharing center and create new entry for pppoe dialer,
# After creating dialer, it will close the Logo and will show you the message that Dialer have been installed.

This is not fully final Script, Few things have been left intentionally, Following functions will not be performed.

# It will not check Duplicate entries. For example, If you have installed the dialer, and want to re.install it again, It will not check duplicate entries, and will stop on DUPLICATE NAME FOUND, So please Delete Previously Created Dialer with the same name.

Please check and Do Let me know the results.

I have checked It on Windows 7 several times and working fine. The speed of executing functions in program can be + or – in some cases, It can be tuned with the $DELAY variable.

So Here we go . . .

First of all you have to download ‘Auto-it‘ software from its website at

http://www.autoitscript.com/cgi-bin/getfile.pl?autoit3/autoit-v3-setup.exe

I used Latest version: v3.3.6.1, Do full installation of AutoiT.

After installation, launch it by  Goto Start / Programs / Autoit v3  and select SciTE Script Editor

Now an advance Notepad type windows will open, Just paste the following code in it.

(Note: FOR SOME REASONS, Sometimes CODE Does not displayed PROPERLY IN THIS BLOG, IF you face syntax errors,  you can copy the raw code from following location) http://pastebin.com/BhNSMeKx

#cs ----------------------------------------------------------------------------
AutoIt Version : 3.3.6.1
Author : SYED JAHANZAIB
Email : aacable@hotmail.com
Web : https://aacable.wordpress.com
Script Function: Template AutoIt script. for PPPoE Dialer Installer
OS Supported   : Windows 7
Dated          : 27/09/2011
#ce ----------------------------------------------------------------------------
; Script Start - Add your code below here

$DELAY = 300
$answer = MsgBox(4, "PPPOE Connection", "This script will create a PPPOE DIALER, Do you want to Continue?")
If $answer = 7 Then
Exit
EndIf

WinMinimizeAll ( )
; Put Logo in front and do installation in background, place dialer.jpg in the same folder
; From you have launched dialer.
SplashImageOn("Please wait Few Seconds While Installer Installs PPPoE Dialer ", "dialer.jpg", 800,650)

$COMPANY_NAME = ("Type Your pppoe service name here")
; Example $COMPANY_NAME = ("MY_ISP")
$DELAY = 300

; Run Windows 7 Network Setup
Run("control.exe /name Microsoft.NetworkAndSharingCenter")
Sleep($DELAY)

; Send TAB 7 times to Select 'setup a new connection'
Send("{TAB 7}")

; Send Enter to Launch 'setup a new connection'
Send("{ENTER}")

; Send Next to select 'Connect to Internet'
Sleep($DELAY)
Send("!n")

; Send 'S' to select 'Setup a new connection anyway
Sleep($DELAY)
Send("!s")

;Check Duplicate Connection ???

Sleep($DELAY)
Send("!n")

; Send 'r' to select 'Broadband PPPoE'
Sleep($DELAY)
Send("!r")

; Send TAB 4 times to Enter 'ISP NAME'
Sleep($DELAY)
Send("{TAB 4}")
Send($COMPANY_NAME)
Sleep($DELAY)

; Send 'c' to connect $COMPANY_NAME service to contiue further
Sleep($DELAY)
Send("!c")

; Send 's' to skip connect '$comapany name' service to contiue further
Sleep($DELAY)
Send("!s")

; Send 'c' to close.
Sleep($DELAY)
Send("!c")

WinClose("Network Connections")
Run("control.exe /name Microsoft.NetworkAndSharingCenter")
Sleep($DELAY)
Send("!F")
Send("c")
SplashOff ( )
Sleep($DELAY)
Run("control ncpa.cpl")
WinWaitActive("Network Connections")
Sleep($DELAY)
;send ( "!{TAB}" )
Sleep($DELAY)
MsgBox(0, "Setup Complete", "Your Dialer have been installed , Click Connect on  " & $COMPANY_NAME & " to initiate Dialing")

Now Open File / Save and name it ‘pppoe-win7-dialer-installer’

Now your script with source code is ready to be compiled in .EXE executable format so any user can install it like any other normal application.

Now Open Tools and click on ‘Compile’ and it will compile the script in .exe format and it will save it to the Desktop or whatever Path You have selected.

Now click on pppoe-win7-dialer-installer.exe and it will install the pppoe dialer and place its shortcut on Desktop. Its always better to test the script fully before compiling it, as compilation is done when your program is fully tested and good to go.

Any suggestions on improvements and enhancements / advancements are most welcome and will be appreciable

Regard’s
SYED JAHANZAIB

23 Comments »

  1. help plia,I am understanding mikrotik thru ur help………..my bullet is properly configured………..I think its my NAT or other settings making my ports 3 4 & 5 have no traffic to send. My clients can see my bullet wireless device but with no internet PLEASE HELP!!!!!!!!!
    Below is my terminal commands.please edit them to make my ports have traffic!!!!

    /ip address add interface=ether1 address=62.8.93.141/24
    /ip dhcp-client disable 0
    /ip dns set server=41.212.3.2
    /ip dns set allow-remote-requests=yes
    /ip route add gateway=62.8.93.1 dst=0.0.0.0/0
    /ip firewall nat add chain=srcnat action=masquerade out-interface=ether1

    Like

    Comment by kabuchi wanjau — October 2, 2011 @ 3:44 AM

  2. At first i would like to thank you for this script that you made for windows xp it works like a charm. I have been looking for something like this for a while now but bro the script for windows 7 is not working out for me. I tried to copy and paste the script from both your wordpress site and pastebin but it dosent seem to work. can you please help me out here. Thanks in advance.

    Like

    Comment by Ali Sayed — October 17, 2011 @ 6:35 PM

    • win7 is quite complicated due to its new features.
      there are 2 versions of pppoe dialer script for win7, if the first version is not working for you, try 2nd one,
      At which screen exactly its stopping or what exactly the error you are facing ?

      Like

      Comment by Pinochio~:) — October 18, 2011 @ 10:54 AM

      • Thanks for you reply. I made the script exactly as written in your site but when i try to execute it the script just minimizes all the application and opens up network and sharing centre but after that it dosent do much more then make some beeps and brings up a messege box at the end saying your connection has been created where there is none in the change adepter settings box. Thanks again.

        Like

        Comment by Ali Sayed — October 19, 2011 @ 1:45 AM

    • Its Working perfect .. just unplug ur Etheret cable and make sure there are not available another connection .. ant run setup .. Working full .. and in the scrip u just change ($COMPANY_NAME = (“Type Your pppoe service name here”)) type ur company name here chang to ur company name like this ( PAk_net) before save script and check 🙂

      Like

      Comment by Ali Khan — April 25, 2013 @ 8:29 AM

  3. its very2 usefull for me..
    thanks..
    anyway where the second version?
    “there are 2 versions of pppoe dialer script for win7”
    i use search but just find this and xp pppoe.
    🙂

    Like

    Comment by yanu — February 24, 2012 @ 6:08 PM

  4. why i cant compile at vb 6?
    sorry im newbi. 😦

    Like

    Comment by yanu — February 27, 2012 @ 4:10 AM

  5. thanks.. 🙂

    Like

    Comment by yanu — February 29, 2012 @ 6:41 PM

  6. can i make a temporary connection?
    i mean when disconect / turn off my computer then this connection delete.
    like modem dialer.

    Like

    Comment by aYee — March 7, 2012 @ 2:36 PM

  7. Good Work Sir Allah apko Hamesha Khush rakhe…Sir mane apke blog say bohat kuch sekha han thnx Sir ap hamre liye itna kuch karte han

    Like

    Comment by Arsalan Malick — December 18, 2012 @ 9:42 PM

  8. i am Sorry to say it’s Not work in win7

    Like

    Comment by Mudasar Aman — December 30, 2012 @ 4:26 PM

    • this script was left incomplete dueto some busy schedule. i dont remember exactly but it did create connection only if there is no previous connection made or something like this.

      Like

      Comment by Syed Jahanzaib / Pinochio~:) — December 30, 2012 @ 9:30 PM

  9. Hi Sir!

    It is also work in win7 i try it personally …………. it is a nice script………….thanks Sir …………. My Prob is solved ……….Thanks Sir
    Allah Hafiz

    Like

    Comment by Muhammad Shahjehan — April 21, 2013 @ 12:35 PM

  10. Its Working perfect .. just unplug ur Etheret cable and make sure there are not available another connection .. ant run setup .. Working full .. and in the scrip u just change ($COMPANY_NAME = (“Type Your pppoe service name here”)) type ur company name here chang to ur company name like this ( PAk_net) before save script and check

    Like

    Comment by Ali Khan — April 25, 2013 @ 8:35 AM

  11. ERROR: Gateway Timeout how we solves this prob tell me bro

    Like

    Comment by ayankhan — September 25, 2013 @ 11:15 PM


RSS feed for comments on this post. TrackBack URI

Leave a comment