Syed Jahanzaib Personal Blog to Share Knowledge !

December 30, 2013

DMASOFTLAB Radius Manager: Table ‘radius.rm_wlan’ doesn’t exist

Filed under: Radius Manager — Tags: , — Syed Jahanzaib / Pinochio~:) @ 9:20 AM


Short reference:

While accessing RM users section , I received “Table ‘radius.rm_wlan’ doesn’t exist” error.
As showed in the image below . . .

rm_wlan errorThis is how I fixed it.

On your RM box, create a file in which we will add table information.

touch rm_wlan.sql
nano rm_wlan.sql

and paste following text.

-- Table structure for table `rm_wlan`

CREATE TABLE `rm_wlan` (
`maccpe` varchar(17) default NULL,
`signal` smallint(6) default NULL,
`ccq` smallint(6) default NULL,
`snr` smallint(6) default NULL,
`apip` varchar(15) default NULL,
`timestamp` timestamp NOT NULL default CURRENT_TIMESTAMP on update CURRENT_TIMESTAMP,
KEY `maccpe` (`maccpe`)

-- Dumping data for table `rm_wlan`

SAVE and exit.

Now use the following command to import table into mysql database ‘radius’.

mysql -h localhost -u root -pYOURPASS radius < rm_wlan.sql


The table code have been extracted from radius manager installation archive.  Example:

You can import any missing table from above file and import it in mysql.

Syed Jahanzaib


  1. Salam Dear Jahanzaib brother. I am using RADIUS on Windows server 2003. i am done with every initial things. my issue is the external user from MYSQL database are connected with radius after authenticating but i am unable to control the concurrent connection of these users. i want to set their limit to 1. can you help me. Kindly mail me if you come up with some solution. my email is :

    Comment by Zubair — May 5, 2014 @ 12:54 PM

  2. Hello Sir,

    I am following your blog.

    I have created MASTER-MASTER replica in mysql as per your guidance. But its keep crashing and error says rm_wlan existing. Even I am creating this table as per your this blog. it work for sometime and crashed again.

    Can you help me what could be the reason for this ?


    Comment by Mihir Pandya — January 15, 2016 @ 11:49 AM

    • Same Problem with me….its keep crashing with same error like rm_wlan does not exist…. Even though I have set skip counter to larger value….it start again

      Comment by Mihir — February 7, 2016 @ 3:25 PM

RSS feed for comments on this post. TrackBack URI

Leave a Reply

Fill in your details below or click an icon to log in: Logo

You are commenting using your account. Log Out / Change )

Twitter picture

You are commenting using your Twitter account. Log Out / Change )

Facebook photo

You are commenting using your Facebook account. Log Out / Change )

Google+ photo

You are commenting using your Google+ account. Log Out / Change )

Connecting to %s

Blog at

%d bloggers like this: