Syed Jahanzaib Personal Blog to Share Knowledge !

May 29, 2018

Vmware ESXI Upgrade Path Notes

Filed under: VMware Related — Syed Jahanzaib / Pinochio~:) @ 1:34 PM

Few days back, we did major upgrades in our data center including esxi upgrades and some network related rack replacement. We were running few vmware esxi 5.0 servers along with vcenter 5.0. To upgrade all servers with 6.5 , we follows below path …

  • Added new 6.5v Vcenter * recommended*
    [OR upgrade existing 5.x Vcenter to 6.5 VC]
  • Now Upgrade each esxi server to 5.5 one by one
  • Now Upgrade each esxi server to 6.5 one by one
  • Now add all esxi servers into new VC 6.5 & all Done 🙂

I had the esxi ISO in CD, therefore I shutdown the all VM guests, and then …

  • Rebooted the esxi server from the ESXI ISO CD
  • It auto detect the previously install esxi, and I just selected UPGRADE

& everything went smoothly.


VIB error when upgrade from 5.5 to 6.5

esxi vib error

When I tried to upgrade from 5.5 to 6.5 it gave some VIB errors as showed in the image above. (It was taken with nokia 3310 🙂

To resolve conflicting VIB, I enabled SSH on the esxi host, logged in via ssh, and issueed following

~ # esxcli software vib list |grep Broad

brcm 550.2.5.11-000000 Broadcom VMwareAccepted 2018-05-26
misc-cnic-register 1.78.75.v55.1-1OEM.550.0.0.1331820 Broadcom VMwareCertified 2018-05-26
net-bnx2 2.2.4f.v55.3-1OEM.550.0.0.1331820 Broadcom VMwareCertified 2018-05-26
net-bnx2x 1.78.80.v55.3-1OEM.550.0.0.1331820 Broadcom VMwareCertified 2018-05-26
net-cnic 1.78.76.v55.7-1OEM.550.0.0.1331820 Broadcom VMwareCertified 2018-05-26
net-tg3 3.135b.v55.1-1OEM.550.0.0.1331820 Broadcom VMwareCertified 2018-05-26
scsi-bnx2fc 1.78.76.v55.1-1OEM.550.0.0.1331820 Broadcom VMwareCertified 2018-05-26
scsi-bnx2i 2.78.76.v55.1-1OEM.550.0.0.1331820 Broadcom VMwareCertified 2018-05-26

# In my case the conflicting driver was net-bnx2x so I just removed it using below command,

~ # esxcli software vib remove -n net-bnx2x

Exit, & Rebooted, afterwards upgrade the esxi 6.5 worked well.


Datastore Conflicts with an existing datacenter that has the same URL

When I removed one esxi from the VC 6.5 & and tried to add it again, it gave following error

olddatastorage.JPG

After inspection, it came to my knowledge that one of guest from another esxi server is using this data store , I simply moves this to another esxi, and then the host got added successfully !


Regard’s
Syed JahanzaiB

%d bloggers like this: