Syed Jahanzaib Personal Blog to Share Knowledge !

About ME

Assalam Va Alaekum, ♥

My name is Syed Jahanzaib, and I am from  Pakistan. I am in the field of computer & networking since year 1996.  Currently working as a Systems Administrator in a private company where responsibilities are to manage Microsoft / IBM and Cisco related environment.Mostly include, Windows 2003/2008 Servers, AD, ADC, FS, WDS, WSUS, SAV, VM, ESXI, IBM Lotus Domino/clustering, HA, Cisco ASA, Managebale Switches, TMG 2010, CNMS, etc etc.

I have done few computing & networking courses including MCSE 2003, MCITP, CCNA , Linux Administration, Microsoft Exchange Server 200/2003 and 2010 & few others from CTTC institute throughout my career.

I started this blog back in year 2009.I have not shared this knowledge to gain financial benefits, I observed that internet is full of theory and huge tutorials, but sometimes, a person requires to the point practical examples. I am sharing this knowledge and my personnel experiences for those people who want to learn new things on there own & through R&D (Research and development) and they need some practical information on various aspects, and also for those who cannot afford to hire paid training from the institutes and professionals, and also for those who cannot pay high consultancy charges from the professionals to manage there small networks like cable.network/cyber cafes etc.

After publishing these resources, many people around the globe, and specially in Pakistan , have manage to improve there network using MikrotikLinux on there own.

These kind of blogs only give them a little confidence in taking there first step, rest of things, they handle on there own🙂

IMO, It’s a kind of Sadqa-e-Jaariya.

My complete profile can be viewed at
http://pk.linkedin.com/pub/syed-jahanzaib/24/3b/407

Regard’s
Syed Jahanzaib

194 Comments »

  1. Jahanzaib! just contact me in case ur interested in freelance work on Microtik

    Comment by Anwar — November 17, 2011 @ 8:24 PM

    • I do work on freelance basis or project basis.
      Please describe in details your requirements.

      Comment by Pinochio~:) — November 18, 2011 @ 12:45 AM

      • dear , does anyone have a solution for caching android and iphone application in Lusca
        it is not working

        Comment by chady — October 18, 2012 @ 10:22 AM

    • i want to know how to configure transparent cashing server step by step because i don’t know lunix

      Comment by sabbir — November 21, 2012 @ 2:21 AM

    • sir plz meri help karein apka ahsan hoga mujh per plz meri koi help nahi kar raha hey mein linux mein server configure karna seekhna chahata hun plz help me plz my name is farhan yousuf from karachi

      my email is… farhan.webxs@gmail.com

      my number is…. 0321-2080078

      regards…. farhan yousuf

      Comment by farhan yousuf — November 17, 2013 @ 6:05 PM

    • Hello Syed Jahanzaib, im following you for some time now, and i really appreciate your talent. I have some work for you can you share your skype so we discuss this?
      Regards,

      Comment by Richard — January 21, 2016 @ 4:41 PM

  2. hi mr.Syed Jahanaib can i add you in my mail to chat or u can help me in networking or give me any reference to working withe mikrotik os

    thanks

    Comment by fakher mousawi — January 1, 2012 @ 2:11 AM

  3. sir main mikrotik ke installation sekhna chahta hoon

    Comment by Owais — January 7, 2012 @ 7:41 PM

  4. assalam mu alaekum …
    I am very impressed with the ability mr.Syed Jahanaib, may you continue to enlighten me of the writings that you created
    I am from Indonesia, I want to learn from you, hopefully get a reply from the god
    sorry if my english is not good

    Comment by akunk — January 29, 2012 @ 8:25 PM

  5. Al salam alekom w rahmat Allah

    very amazing work Mr.Sayd ,thanks for all the help and experience that you give to the world !!
    I need some help please,i send you an email describing my problem
    in brief ,I have 2 ADSL’s line ,192.168.1.1 ,192.168.2.1
    I need to split my users in two groups,A&B ,A take NET from ADSL1 ,B take NET from ADSL 2
    both groups from same LAN
    in hotspt and PPoE servers
    Many thanks in advanced sir

    Comment by Firas A.kAreem — February 8, 2012 @ 8:11 AM

  6. I see that Article ,it has same what I need (but it didn’t include Hotpot or PPoE + it didn’t work !)
    http://wiki.mikrotik.com/wiki/Load_Balancing_over_Multiple_Gateways

    Comment by Firas A.Kareem — February 8, 2012 @ 4:45 PM

  7. Sir, You are really great indeed😯 i’m very appreciate your sharing:mrgreen: btw, do you have any tutorials about creating VPN Server with MikroTik ?
    i already made and works but when i connected to my MikroTik VPN Server, my VPN Client can’t ping nor browse any other IP Address beside it ( only can ping and connect to MikroTik itself using winbox from outside/internet)

    i already use proxy arp in MikroTik’s LAN Ethernet but still can’t. My VPN Client Subnet Mask is : 255.255.255.255 and it’s gateway is pointing to same IP

    Comment by willykk — February 27, 2012 @ 9:06 AM

    • I haven’t worked on VPN scenario much, therefore Can’t give u authentic reply. sorry
      I guess there is a option of use default gateway in client vpn dialer, remove tick from it, and then check,
      Search the google for better answers.

      Comment by Syed Jahanzaib / Pinochio~:) — February 27, 2012 @ 5:17 PM

    • dear willykk i am also facing that problem if your problem is solved then plz reply me back at akeel.shouket@gmail.com about this solution

      Comment by Akeel Shouket — August 19, 2016 @ 10:57 AM

  8. AOA Jahanzaib bhai main ne recently mikrotik ke bare main parha hai main chahta ho ke is ki tamaam configuration ker lo from 0 to 100…… kuch kare humare liye abhi kuch nahi pata is ke bare main linux ka idea hai microsoft ka idea hai is ka kuch nahi hai.

    Comment by Muhamamd Nauman — February 29, 2012 @ 10:29 AM

    • No one can do 100% , not even the most experts can claim 100% achievement.
      Mikrotik is deep subject in itself.
      First set your goals.
      Try with Basics, then move on step by step.

      Remember, The Key to Success is R&D (Reasearch & Development).
      Read, Read, Read, Test , Test Test and you will achieve your goal.
      I also followed the above path and I achieved my set goals.

      Comment by Syed Jahanzaib / Pinochio~:) — February 29, 2012 @ 12:03 PM

  9. AoA,

    Reached your site through google (was looking for a solution to DASD error). But I am more glad to see someone working on Lotus/Domino in Pakistan. I, myself working on Lotus messaging system since 6 years. Maybe we can share our experiences to learn and improve ourself in Domino field.

    Goodluck on your work.

    Haroon Qamar

    Comment by Haroon — March 5, 2012 @ 7:59 PM

  10. Assalam u Alaiykum
    how to configure mikrotik 4 bandwidth loadbalance and mac+ip based users?

    Comment by Muhammad Amir Iqbal — March 20, 2012 @ 12:36 PM

  11. Dear Bro. i am also running a Internet cable with 80 users. i start it with ISDN line. and now i m using PTCL lines. i want to improve it please give some suggestions…… Thanks

    Comment by Junaid — April 11, 2012 @ 4:57 PM

  12. asslam u alaiykum

    sir main aik complete mini isp settup lagana chahta hon mikrotik ki main complete configration ker leta hon
    muje linux,squid,fedora k barey main information laini thi k in ki config aap online ker do ge jo payment banti hai wo main aap ko ker don ga
    AIRNET PVT LTD.

    Comment by shani — April 12, 2012 @ 12:04 PM

  13. sir mainey direct web,meltinet, se bandwidth parchase ki hai sir mainey c class ip pool b parchase ki hain sir cindly mujey live ip pool ki setting ka koi script dain k main private ip corporate clinte ko de sakon with mikrotik
    thx

    Comment by shani — April 12, 2012 @ 12:09 PM

  14. Sir, i have asked a single thing in multi topic n multi time. i need a suggestion. i have cruntly running internet cable and have 200 clients. useing ISA serve 2004 with trafic shaping by bandwidth spliter.
    i want to know that
    isa server 2004 is better
    or
    mikrotik pppoe server
    ????
    kindly suguest me sir,. realy very thanks full to you.

    Comment by faru — April 14, 2012 @ 12:03 PM

    • You are posting in wrong place. Use my email for suggestions.

      ISA or Mikrotik, both are good in there own ways.
      I have used ISA Server with Bandwidth Splitter for about 10 years, and found it very good in terms of user browsing experience. But As Microsoft is limited in there own domains, for example, you cant create pppoe / dialup server in it, You can’t cache Dynamic contents like Youtube in ISA Server. Actually You can’t modify it after a limit. I have written an short guide on how you can create VPN Base Dialup Server on same ISA Server, so only users who connect there pc via vpn dialer will be able to access internet.

      On the other hand, Mikrotik have some benefits over ISA, it is highly customizable, you can also load balance multiple WAN link on it using various policy base methods, But it donot have good cache proxy builtin, you have to use external Proxy Server like SQUID along with Mirkotik for good caching function.

      Actually You shouldn’t be doing comparison between these two giants. Both are good in there own domains.
      Install Mikrotik in Your test lab and do some testing , then do comparison on it.

      Comment by Syed Jahanzaib / Pinochio~:) — April 14, 2012 @ 2:23 PM

  15. thx for your kind reply but sir i have emailed you 4 time but i dint get even a single reply…….. so after feding up i typed here.

    Comment by faraz — April 15, 2012 @ 12:34 AM

  16. Sir,is There have possibity about multiple PTCL EVO loadbalcing with mikrotik?

    Comment by Khalid Imran — April 20, 2012 @ 9:16 AM

    • I have not tried them yet, but i guess there shouldn’t be any issue as long as you have multiple gateways available on mikrotik RouterOS

      Comment by Syed Jahanzaib / Pinochio~:) — April 20, 2012 @ 11:10 AM

  17. salam… muje (isa 2004) me masla temp files ka bohet aata ha.. isa temp file bohet Garnet karta ha.. koi hall ha is ka..?

    Comment by maqbool366 — April 20, 2012 @ 10:48 AM

  18. sir mane kise or kah net online lay kar apny pass use karna hai. kiya ap esa kar sakty hai. iam waiting your reply…….

    Comment by shahzad — April 23, 2012 @ 7:29 PM

  19. for example mane lahore or other & country say net lay kar mulatn use karna to

    Comment by shahzad — April 23, 2012 @ 7:30 PM

    • There are various ways to get it done.
      Either via using 3rd party Fiber (Metro) or use your own Wireless Equipments to make point to point connectivity.

      Comment by Syed Jahanzaib / Pinochio~:) — April 25, 2012 @ 10:55 AM

  20. sir mare factory my i think net to port faward kar k TeamViewer kay zariy chalaya hua hai. jab ma gateway ip opne karta ho to yah lakha hua ata hai.
    This site is running TeamViewer.
    Free Port 80 for other applications in advanced settings
    or mary pc k local eara my 1Lan ka link ha. or dosra kuch create kiya hua hai. es name say. DSL ON MIS-3 or(internet Gateway).
    yah picture ap dhak lay may be apko samhaj a jay mare baat ki…
    2 link ha jo opne ho jay apk pass

    http://tinypic.com/r/25i27o0/6

    Comment by Shahzad Nasir — April 28, 2012 @ 7:29 AM

  21. AOA Syed sb I would like to talk about work related to linux based servers. If you have time kindly get in contact via marwansaleem@gmail.com. I await your kind response. Regards Marwan Saleem

    Comment by Marwan Saleem — May 15, 2012 @ 8:18 PM

  22. Hello Thanks For your Mikrotik Share Knowladge.Please New Post Mikrotik Dhcp Configure and descrived telnet port change and access pc.

    Comment by Anower ullah — May 25, 2012 @ 7:40 PM

  23. g

    Comment by hesham — May 26, 2012 @ 2:17 AM

  24. dear sir , thank you for helping us , please i want to make browesing out of limitation , i mean , even if user get max mitation of accountstill can browes easy . and thank you in advince for help

    Comment by Ahmad S. — June 15, 2012 @ 3:15 AM

    • Clarify your goal.
      You can mark port 80 and create separate Queue for it as per your requirements.

      Comment by Syed Jahanzaib / Pinochio~:) — June 16, 2012 @ 10:13 AM

      • thank you for your replay , my goal , when users reached download limitation ( lets say 512kbps ) by using download manager or something similar , they loss brows when they want to brows what i want , give brows priority even if they reach limitation , so they can brows even if they reach 512 easy
        hope i could explain it in good way
        regards

        Comment by Ahmed S. — June 16, 2012 @ 4:12 PM

      • You need 3rd party Radius Server for this custom requirement, Best adn cheap radius server is DMASOFTLAB RADIUS MANAGER. Try it. its very worthy.

        Comment by Syed Jahanzaib / Pinochio~:) — June 18, 2012 @ 8:47 AM

  25. dear sir ,thank you for your replay , i already use radius server ( damasoft ) , is there any sugestion i can do it in service profiles ? thank you in advince

    Comment by Ahmad S. — June 22, 2012 @ 1:38 AM

    • You can impose quota limit in there profile, so after reaching specific quota for the day, there speed should be decreased to half or even less for rest of the day session. Also there are few advance customization you can do, but you have to really read a lot how billing plans and packages works in DMASOFTLAB , if you are using hotspot , then chances are you can do high customization, but for pppoe/vpn, options are limited , one such feature is on the fly bandwidth change for hotspot, but not supported for pppoe , Read n Read

      Comment by Syed Jahanzaib / Pinochio~:) — June 22, 2012 @ 9:01 AM

  26. Hi,

    I’m using Radius Manager 4.0 for PPPoE with CISCO NAS.
    Everything is fine except the usage graph which is not available in RM 4.0 Version.

    PPPoE Customer will use the RM UCP for viewing their details , So I want to show them thier uage graph also.
    So plan to import the mrtg link to the RM but could perform using the radius database and radius froont end.
    I can edit the htm file and i had to insert the ink which will go to the database.
    + one more the graph link should associate with the actual username and password as pppoe users will use username/password to login to teh UCP.

    I used to read your blogs and have posted some earlier too.

    -shiva

    Comment by Shiva Thapa — June 22, 2012 @ 10:10 AM

  27. Yes, I want to link to mrtg server where we will have the pppoe customers graphs link.
    Just couldnot get the idea how ? I have planned to create a different database from radius database but the problem is : we wiil have the pppoe user based mrtg link , need to insert the mrtg link into the database. and dont know hiow can the two tables be related ..

    Comment by Shiva Thapa — June 22, 2012 @ 10:22 AM

  28. i need to install new email server in linux (fedora core 14) kindly help me. my contact number is 03072162240

    Comment by Farrukh Shehzad — July 4, 2012 @ 5:57 PM

  29. Assalam O Alaikum!
    Dear Sir i am running a small net cafe along with 30 home users setup. Right now i m using ISA server with bandwidth splitter. Now i want to make some configurations so that all users make dial in account to use the internet. What are the requirements for this setup.
    I’ve read about the Mikrotik that its low cost setup, but i don’t know much about it, so please give me some advice on how make it possible.
    Regards,
    Fawad Meer

    Comment by fawadmeer — July 16, 2012 @ 6:09 PM

  30. Asalamualikum sir Very nice main kafi Arsay say ap ki post wagara dekh raha hon or kafi info milti hai ap k ilam say or bohat piyra samjhtay hai nice allah ap ko humesha kamiyab karay har achay maksad main …..

    sir mujhey eik or baat pochni thi k main hum log mikrotik per ya squid per Mac Address say net chalatay hai is k ilawa bhi kuch hai jiss say yani maslan mere pass wifi chal raha hai tu mera eik user tha jesy us ka ip tha 192.168.2.7 tu ab us nay net khatam karwa diya tu us ka id pirh bhi humare network chaley ga jiss say humare or users ko problm hogi jesy koi next user aye tu us ko main same ip deyta hon tu pirh aapas main jhang karay gey ….. is k baray main zara bataye k kiya hall hai is ka

    Comment by Rizwan Ahmed — July 22, 2012 @ 12:08 AM

  31. Plase i have add u on yahoo
    amr_wireless
    i want ur help about something in mikrotik . PCC
    plase add me i want open with u online
    thank u

    Comment by amrnetworksmed — August 27, 2012 @ 6:37 AM

  32. Sir i want to contact you regarding mikrotik. Please give me your mobile number or any other contact information. i am Zeeshan from kuwait. I have round 100 costumers and i want to manage them via mikrotik. i am new to mikrotik. i almost done just a small favor required by you. Please do help. I shall be very thankful to you.

    Comment by Zeeshan — September 10, 2012 @ 4:20 AM

  33. Assalam -0-alikum
    how to crack pac proxy… in domain enviorment.

    Comment by Haidar imam — September 20, 2012 @ 1:33 PM

  34. Can you share me your contact details at nishit@vertax.co.in with your skype details and your best time to communicate….

    Comment by nishit — October 24, 2012 @ 9:11 AM

  35. Hi. Just found your blog. Just wanted to tell you Thank you very much.

    Comment by Vlad — November 5, 2012 @ 1:54 AM

  36. Salaam,
    dear sir, My name is Maihan from Afghanistan and i am new with mikrotik devices and i need the configuration for VPN in Mikrotik router boards RB1100 for two site of our office, both offices are connection to two different ISP please help me out here as i am a fun of your blogs.
    you can contact me on (maihanafg@yahoo.com, Skype id: maihan.satarzai)

    thanks in advance

    Comment by MaIHaN — November 6, 2012 @ 11:12 AM

  37. Dear Syed Jahanzaib
    I have problem in User Manager 5.18 -Mikrotik- configuration, I setup US mores one but one problem I have, “no valid profile found”
    This is my Raduis configuration :

    /tool user-manager profile limitation
    add address-list=”” download-limit=0B group-name=”” ip-pool=”” name=512 rate-limit-min-rx=131072B \
    rate-limit-min-tx=524288B rate-limit-rx=131072B rate-limit-tx=524288B transfer-limit=0B upload-limit=\
    0B uptime-limit=0s
    add address-list=”” download-limit=0B group-name=512K ip-pool=”” name=1Month transfer-limit=0B \
    upload-limit=0B uptime-limit=0s
    add address-list=”” download-limit=0B group-name=512K ip-pool=”” name=1D transfer-limit=0B upload-limit=\
    0B uptime-limit=0s
    add address-list=”” download-limit=0B group-name=512K ip-pool=”” name=5124 transfer-limit=0B \
    upload-limit=0B uptime-limit=0s
    /tool user-manager customer
    add backup-allowed=yes currency=NIS disabled=no login=admin parent=admin password=”” \
    paypal-accept-pending=no paypal-allowed=no paypal-secure-response=no permissions=owner \
    signup-allowed=no time-zone=-00:00
    /tool user-manager profile
    add name=1Month name-for-users=1Month override-shared-users=1 owner=admin price=70 starts-at=logon \
    validity=4w2d
    add name=1d name-for-users=Day override-shared-users=1 owner=admin price=10 starts-at=logon validity=1d
    add name=5m name-for-users=5M override-shared-users=1 owner=admin price=0 starts-at=logon validity=5m
    add name=2m name-for-users=2M override-shared-users=1 owner=admin price=0 starts-at=logon validity=2m
    /tool user-manager profile profile-limitation
    add from-time=0s limitation=5124 profile=1Month till-time=23h59m59s weekdays=\
    sunday,monday,tuesday,wednesday,thursday,friday,saturday
    add from-time=0s limitation=5124 profile=1d till-time=23h59m59s weekdays=\
    sunday,monday,tuesday,wednesday,thursday,friday,saturday
    add from-time=0s limitation=5124 profile=2m till-time=23h59m59s weekdays=\
    sunday,monday,tuesday,wednesday,thursday,friday,saturday
    add from-time=0s limitation=5124 profile=5m till-time=23h59m59s weekdays=\
    sunday,monday,tuesday,wednesday,thursday,friday,saturday
    /tool user-manager router
    add coa-port=1700 customer=admin disabled=no ip-address=127.0.0.1 log=auth-fail name=speed shared-secret=\
    303030 use-coa=no
    /tool user-manager user
    add customer=admin disabled=no name=74 password=”” shared-users=1 wireless-enc-algo=none \
    wireless-enc-key=”” wireless-psk=””

    Comment by Mohammad — December 8, 2012 @ 10:49 PM

  38. Dear Syed Jahanzaib,
    i have problem about seek bar youtube
    my proxy can’t HIT if i use seeking bar on youtube..

    Comment by aryuddin — January 4, 2013 @ 11:02 PM

  39. Mr Syed Jahanzaib, I am a student in an Austrian school in Albania (small country in Europe). I study IT-Networking and this is my last year. I have to do a project that is called “mini isp”, but I would need some help from an amazing person like you. If you can contact me via email I would appreciate it.

    Thank you

    Comment by Ludovik Jakova — January 16, 2013 @ 3:08 PM

  40. Dear Sir,
    adeel here from RWP.
    i m currently using Mikrotik Router board, RB750 GL.
    i m facing no.Browsing Issue. and at that time on LOG some Errors are appearing in RED color.

    dhcp error default : failed to give out ip address: pool is empty
    dhcp error default : failed to give out ip address: pool is empty
    dhcp error default : failed to give out ip address: pool is empty

    kindly help me…, and give me your Email address i will sent you snap-shots of that pictures.
    i am waiting for your Help.
    Please help me…

    thanks for your kindness.

    Comment by adeelhafeez786 — February 14, 2013 @ 11:19 PM

  41. Asalam Alikom
    I,m using mikrotik hotspot system with dmasoftlab radius manager and i’m planing to provide my customer with teamviewor QS module for remote supporting
    I want to use QS without access to internet how can i made walled garden or else for pay pass QS to mikrotik hotspot system

    thanks a lot

    Comment by Hesham Saad — February 15, 2013 @ 8:25 PM

  42. Assalam Sa Alaekum bhai.
    Can you let me know if I can hire you for my Radius Manager and NAS config.
    Viktor firin DMAksoft installed RM but there are some minor things do.

    Salam
    J. Salim

    Comment by Jon Salim — February 27, 2013 @ 9:12 PM

  43. Assalamualikum Sir,
    I need your help to solve my problem…
    I have setup radius manager in my computer, but I cannot configure it because I dont have any static ip in two site of my hotspot area…
    Can you help me to settle this problem…
    need your help…

    Comment by Muhamad Shahir — March 4, 2013 @ 9:36 AM

    • Please describe in detail about your scenario.

      You have readius manager configured, and you want your two sites to take authentication from your Radius Server?
      Are thee two sites are on remote area / internet / different subnet ?

      Comment by Syed Jahanzaib / Pinochio~:) — March 4, 2013 @ 9:47 AM

  44. Assalamuwalaikum. How are you? Can you please tell me how “Facebook”,”Youtube” easily block by mikrotik. I already follow your web proxy instruction but i faced some problem. When i enabled web proxy rule as like you wrote, then some https website can’t open.But i am not block that website. When i disabled then it works fine. I am not create any other rule in mikrotik. I was try to firewall filter rule but same problem i found. Some website can’t open. Like worldbank, ADB website. If possible please help me.

    Comment by Nuron Nabi Shajib — April 2, 2013 @ 11:01 AM

  45. Hi Syed… thanks for great blog… wonder if you can help with old password recovery from Radius Manager for users. Currently when users click ‘Password Recovery’ it offers to create new password. This is a problem since pppoe is on CPE and users do not know how to edit CPE pppoe login info. User should click ‘Password Recovery’ enter email address and username for authentication and then get return email with username and password.

    Comment by Grant — April 26, 2013 @ 1:42 PM

  46. Can you please guide me for using kannel-1.5.0. I have installed it but I do not have any GSM modem nor SMSC setting. Where can I get SMSC settings and can you tell me that do kannel have its own php code or we have to write it ourself. I am sending and receiving msges through fakesmsc. and I wrote a php code myself. but In your tutorial you showed some pic on your browser which shows that kannel have its own php/html code.

    Comment by Hamid Raza HAshmi — May 7, 2013 @ 3:04 PM

  47. Hi Syed,

    I am currently working on a setup for a college. The bandwidth is a small bandwidth and will require web-cache to boost the performance. However, I will like to shape the bandwidth with for 5 subnets (192.168.10-14.0/24) but the simple queue is not working. I marked connection and packet-mark at the prerouting chain.

    Kindly guide me on the appropriate chains to mark the connections and packets.

    Regards

    Comment by Abiola Oseni — May 16, 2013 @ 5:04 AM

    • How users are connected to your mikrotik server? If you are using HOTSPOT or PPPOE server, then you can simply use profile to create dynamic queue

      Comment by Syed Jahanzaib / Pinochio~:) — May 16, 2013 @ 10:04 AM

      • Hi Syed, thank you for your prompt response. I will prefer to use HTB with child queues as this will allow the bandwidth to be fully utilized. My intended setup is address-list=>mangle=>simple queue (parent, priority, limit-at and max-limit). Mangling at the appropriate chains is my confusion.

        any suggestion ?

        regards

        Abiola

        Comment by Abiola Oseni — May 16, 2013 @ 12:25 PM

  48. Hi Syed
    I need help setting up a Ubiqquiti Bullet M5 as an access point on my mikrotik RouterOS, I have one network point available for the Ubiqquiti Bullet M5 to connect to the mikrotik RouterOS pc. Can you please help me on to set it up.

    Stephan Booyzen

    Comment by booyzen — May 19, 2013 @ 1:27 AM

  49. Hi Syed,

    Is it possible to have load balancing (using PCC) and bandwidth manager in the same box ? if Yes, any guide

    Comment by Abiola Oseni — May 30, 2013 @ 8:17 PM

    • Yes its possible. you dont need any guide for it. just configure pcc, and if you are using pppoe/hotspot, they will create dynamic queue (or depend on your config)

      Comment by Syed Jahanzaib / Pinochio~:) — May 31, 2013 @ 11:59 AM

      • Hi Syed, thank you for your prompt response. My client is sharing internet among its branches and is not using PPPoE or hotspot. Also, he wants advanced QoS in which excess bandwidth can be utilized by the branches whenever it is available. Hence, this will require address-list, mangle, parent and child queues.

        Going by numerous mangle rules for required for PCC, can we have set of mangle rules for connection mark and packet marks in the same box ? i will appreciate your guide on this.

        regards

        Abiola

        Comment by Abiola Oseni — May 31, 2013 @ 1:32 PM

  50. Zaib bhai, kindly check my website http://www.pringowireless.com and also like my page http://www.facebook.com/pringowireless

    Please give me any best suggest or feedback to improve my wireless network services

    Comment by Jojee — June 27, 2013 @ 3:33 PM

  51. Please can you send me the firewall.rar

    Comment by Mario — July 17, 2013 @ 7:15 PM

  52. Bro I am having problem with queueing can You plz help?

    Comment by Dawood Ismail. — September 6, 2013 @ 3:27 PM

  53. Mr. Syed Jahanzaib, wonderful job i must say is what you are doing. cant even say much this has impacted my skills and made things easier for me. i just want to dare now. Here is my question; in my network (i use mikrotik and usermanager), i wish i could know how to resolve ip addresses to names. i want my customers to be able to check their data and time on their own using a specified names instead of ip address. thanks.

    warm regards.

    Comment by Mayowa — September 9, 2013 @ 3:12 PM

  54. For now, if a customer wants to check his remain time or data, i ask them to go to 192.168.1.50/user (that is my router ip address forward slash USER). Now, a lot of them find the process strenuous. I think if i could convert the ip address to something like data.com would be easier for them to use instead of the ip address.
    Thanks.
    Ward Regards.

    Comment by Mayowa — September 10, 2013 @ 4:26 PM

  55. For now, if a customer wants to check his remaining time or data, i ask them to go to 192.168.1.50/user (that is my router ip address forward slash USER). Now, a lot of them find the process strenuous. I think if i could convert the ip address to something like data.com would be easier for them to use instead of the ip address.
    Thanks.
    Warm Regards.

    Comment by Mayowa — September 10, 2013 @ 9:55 PM

    • Try not to give IP address of your router to user.
      Use DNS name instead.
      Add static entry in DNS like billing.yourisp.com = 192.168.1.50

      This way user will open http://billing.yourisp.com/user

      Just make sure that clients uses you Mikrotik Server IP as there Primary Dns Server (either via dhcp or via NAT rule to force them to redirect there DNS request to mikrotik)

      Regard’s
      JZ

      Comment by Syed Jahanzaib / Pinochio~:) — September 11, 2013 @ 8:38 AM

  56. Thank you for your help sir. I have tried it with no success. Am sure am doing somethings wrongly. could you put me through? or may be a guideline? Thanks.

    Comment by mayowa — September 11, 2013 @ 8:37 PM

  57. That will be great! How do we go about that? i will also like to know if you use IM. And for book, i will surely go through it. Thanks a lot.

    Comment by Mayowa — September 12, 2013 @ 2:20 PM

  58. Assalam-o-alikum

    Can i block Live IPs throught Bandwidht Splitter and limit upload and downloading

    Regards
    Umar

    Comment by muhammad umar — November 16, 2013 @ 11:38 PM

    • Bandwidth Splitter is not a firewall system. It is used only to restrict download/upload traffic and enforce quota.

      Comment by Syed Jahanzaib / Pinochio~:) — November 20, 2013 @ 1:18 PM

      • Assalam-o-alikum ,

        Thank you for your reply .I apologize from my typing error . Can i restrict download/upload traffic enforce quota on live IP /

        Regards

        Comment by muhammad.umar — November 20, 2013 @ 1:34 PM

      • Live ips are configured on user ?
        or described in details on what is the goal?

        Comment by Syed Jahanzaib / Pinochio~:) — November 20, 2013 @ 1:51 PM

  59. Also can u please let me know how can i do this ? Some screen shot , guide would be helpful . Once again thanks for replying

    Comment by muhammad.umar — November 20, 2013 @ 1:40 PM

    • Let suppose there is A user who has live ip configured on his/her workstation then how i can limit download/upload ? If i am not wrong if a person is assigned Live ip then they are no longer part of our network . Please correct me if i am wrong . Await your reply.

      Comment by muhammad.umar — November 20, 2013 @ 1:57 PM

      • By default, even if clients connect from External network to Internal, Bandwidth Splitter treats those connections as ‘inbound’. Which means that your shaping and quota rules needs to be applied to your local addresses (where your servers are), and in destinations you should specify External network (though the actual connections are in reverse direction).
        You can change this behavior by unchecking option ‘Treat connections from External network as accepted/inbound’ in general Bandwidth Splitter properties.

        Comment by Syed Jahanzaib / Pinochio~:) — November 20, 2013 @ 2:26 PM

  60. Scenario is Client are inside my network but using live ip , they are not connecting from external network to internal ? Is it possiable i can limit over them .

    Comment by muhammad.umar — November 20, 2013 @ 3:03 PM

    • TMG can limit traffic that passes from its interfaces only.
      you can use some 3rd party tools like soft-perfect bandwidth manager to restrict bandwidth. or the better way to use central router and pass all traffic from it.

      Comment by Syed Jahanzaib / Pinochio~:) — November 20, 2013 @ 3:10 PM

  61. Sir mujhe apse rabita karna hay plz mjhe apne E-Mail day do ya phir koi cell No. hai tu wo day do plz sir

    Comment by Mak — November 26, 2013 @ 2:07 AM

  62. Hi Dear Syed Jahanzaib,
    I read some of your blogs (how to), were quit useful.
    I am from India and looking for RADIUS server developer for a project. Do you deal with it?
    Kindly let me know if you provide freelancer service.
    Regards,
    Inder P. MEEL

    Comment by ipmeel — December 6, 2013 @ 11:31 AM

  63. hi! I want to implement with microtik a parallel with sequre ISP. Can u help me?

    Comment by Israel Plata — December 21, 2013 @ 6:15 AM

  64. Aslam o alekum sir g
    Ho sekye tu urdu zuban mr apne tutorial benaya keren
    Hemri tera k log b ap se estefadah hasel ker seken
    Urdu tutorial se ziadah asani hi jae gi
    Plesse please meri es hakeer c tajweez par ghur keren
    Mikrotik hotspot .mikrotik pppoe. Squid proxy server
    Etc advance in thanks

    Comment by usman ali — December 22, 2013 @ 8:58 AM

  65. dear sir .. can you help me
    I recieve two Internet package (WAN) from different companies. Each package (WAN) put in the hub switch and then broadcast on the devices to reach customers … Can I shortcut by one broadcast devices run on the packages together using mikrotik device

    Comment by Osama Fadil — January 6, 2014 @ 11:31 PM

  66. Salam,
    i’m using RB750 as load balancer
    configured it just u taught…
    working perfectly
    i’m wondering can i use it filter all my web browsing traffic
    i want to block all my web traffic but only windows live mail to send and receive emails
    is it possible if u already wrote tutorial on that please share link here
    very great full to you
    THNX

    Comment by Shoaib — January 9, 2014 @ 1:07 AM

    • Yes its possible, but you have to first track all the other URL’s hotmail access like live.com, and many others, then create a set of these urls, and allow then in web proxy , then create a general deny rule and place it in last. this way only permitted sites will be allowed and all other sites will be blocked.

      Comment by Syed Jahanzaib / Pinochio~:) — January 9, 2014 @ 8:50 AM

      • is it possible i deny all ports but allow imap, smtp and pop ports only for specific range??
        please share link of tutorial if u have any, related to port blocking on loadbalancer for specific ip range thnx

        Comment by Shoaib — January 10, 2014 @ 3:30 AM

  67. Asslamun alaikum dear brother,

    172.16.10.3 –> 103.246.84.17:80 –> 172.16.10.2:3389

    ip firewall nat add action=dst-nat chain=dstnat disabled=no dst-address=103.246.84.17 dst-address-type=local dst-port=80 protocol=tcp to-addresses=172.16.10.2 to-ports=80
    ip firewall nat add chain=srcnat src-address=172.16.10.0/29 dst-address=172.16.10.2 protocol=tcp dst-port=80 out-interface=LAN-Interface action=masquerade

    where LAN-Interface = Interface where 172.16.10.1 IP is given.

    Also tried
    ip firewall nat add action=dst-nat chain=dstnat disabled=no dst-address=103.246.84.17 dst-address-type=local dst-port=80 protocol=tcp to-addresses=172.16.10.2 to-ports=80
    ip firewall nat add action=src-nat chain=srcnat disabled=no src-address=172.16.10.2 to-addresses=103.246.84.17
    ip firewall nat add chain=srcnat src-address=172.16.10.0/29 dst-address=172.16.10.2 protocol=tcp dst-port=80 out-interface=LAN-Interface action=masquerade

    Am i missing anything?

    Comment by Sadiq ali — January 9, 2014 @ 7:03 PM

  68. sir cashe webmaster error kya hai jab be main lodbalncing krta hon or koi be web open krny tyo ya error ae jata hai :”your web cashe webmaster http proxy mikrotik:” nehy gatway hota hai iss problm ko kasy hal kya ja skta hai plz reply me mara email address ya hai: asif12662@gmail.com

    Comment by Asif Hussain — January 19, 2014 @ 5:32 PM

  69. sir app ki bri mahrbani ho gi agr app iss ka koi hal mujy bta dany gy plz zror halp kejyga mari

    Comment by Asif Hussain — January 19, 2014 @ 5:33 PM

  70. or main RB750GL use kr raha hone Rocket m2 ky sath

    Comment by Asif Hussain — January 19, 2014 @ 5:35 PM

  71. sir , basix language ky program conputer ya laptop pa kiya ja sakhty hain ,,,,,,,,,,,,,,,,,,,,,,plz plz plz telme fast

    Comment by fariha khan — February 8, 2014 @ 10:59 AM

  72. dear sir .. can you help me
    I recieve two Internet package (WAN) from different companies. Each package (WAN) put in the hub switch and then broadcast on the devices to reach customers … Can I shortcut by one broadcast devices run on the packages together using mikrotik device

    Comment by brqjaz — February 11, 2014 @ 1:28 PM

  73. sir …. i need yr help plzzzz
    i work to provide internet >>>> in have two link from two company and i used for each link some device to broadcasting to my users (client) can i inter the two link in one mikrotik box and used one broadcasting device ?????? can you help me in this idea my bro

    Comment by brqjaz — February 11, 2014 @ 1:49 PM

  74. sir we are using mikrotik router os for bandwidth routing from internal to external network, recently we are facing a problem which causing due to the reason of ip conflict all my network is disturbing whenever this scenario occurs so is there any option to find whose the computer that getting conflict using arp pls help me, plz plz

    Comment by Javed — March 4, 2014 @ 1:30 PM

    • The best way is to use IPLESS PPPOE server . this way whatever IP user will put, your server will not effect as it will not itself ahve any ip. this is teh most secure method

      Comment by Syed Jahanzaib / Pinochio~:) — March 4, 2014 @ 2:38 PM

      • Jahanzaib Bhi AOA,

        I have recently started job in Comsats university as a Network assistant and i have some task to resolve, we have to offices one is in F-8/3 and Second is H-8/1 our all feculty members are sitting in our F-8 office and our main cms/lms server is in H-8 office. before my joining we were having only 2 Lines of PTCL internet and was managing with 2 cache servers squid\3 when i joined we took 2 more lines of 4 mb each to make the internet speed better but it was difficult for me to install 2 more proxy servers after PTCL router to prevent this issue i installed Mikro tik router board RB751 and after this router i need only one cache server it was good for only internet uses and was working fine but one thing we notices when we access our CMS or LMS server through this router we are facing problems means when we go to access server some time its open and some times its showing request time out and error 522 that webite (our server is offline) which i understood is that when its sending packet on different WAN connections thats why this happen or some thing else, Now please suggest me what we should do now we have any option to keep continue with router or i have to come back to my old solution, or you have any solution where this router should use same path ( WAN Connection) for data sending and receveing for our server only mean it should not do load balancing for our server.

        Comment by Muhammad Faraz — March 5, 2014 @ 5:03 PM

      • are you having issues at IN or OUT directions?
        add me in skype
        aacable79

        Comment by Syed Jahanzaib / Pinochio~:) — March 6, 2014 @ 8:51 AM

  75. Thanks man you bolg helped my and saved my time

    Comment by Haider Ali — March 5, 2014 @ 3:07 AM

  76. thanks you….for all the grate job

    Comment by georgios peros — March 6, 2014 @ 1:23 AM

  77. Selamu Aleikum !

    Bro, I want to ask you something. I have a Cisco VPN server that use IPSec, now my answer is, can mikrotik act as Cisco VPN Client ?

    Jazak Allah !

    Selam !

    Comment by AlbMikrotik — March 7, 2014 @ 8:37 PM

    • Sorry, that’s my question, not my answer ( tired )

      Comment by AlbMikrotik — March 7, 2014 @ 8:39 PM

  78. Hi,

    Please contact me on me@usman.pro . I got a project to discuss with you.

    Comment by Mian Usman Farooq — March 16, 2014 @ 3:15 PM

  79. Selamu Aleikum !

    sir muja confrom karna hai ptcl vdsl pa current download or upload speed kitni aati hai.

    Comment by AYAN ALAM — April 20, 2014 @ 6:09 PM

  80. Assalam Va Alaekum

    My name is Syed Muhammad Ali sir am trying to implement mIcrosoft exchange server 2003 at home sir i need your email address i send you my snap shoot of my exchange server 2003 step by step lab unfortunately i implement exchange server lab at home i registered domian in godaddy and i also buy static ip from my ISP i facing problem able to recessive eamil external but i am not send email externally .i unable to diagnoses preblem where i mistaking Syed Jahanzaib please sir help me

    Comment by Syed Muhammad Ali — April 22, 2014 @ 5:13 AM

  81. i have 4 lines and i need to make one squid for all of them
    it will be like this
    squid has 4 lines in and 4 lines out
    every in line and out line has a different pool
    every out line to be routed from a spaciefic in line
    can it be done
    thanks

    Comment by ahmed — June 28, 2014 @ 5:26 AM

  82. Hello , Sir , could you please write an article that how can connect the fiber optic internet to mikrotik ? I have a static IP address but it is not /30 and also Bridge mode does not work , please write me how can control completely by mikrotik.
    Thank you very much .

    Comment by Mahmoud Sheikhian — July 8, 2014 @ 6:51 PM

  83. hello sir,could you please write an article about build mail server using zimbra, from beggining. i all ready search on internet, but most of article not give a solution for me,i mean the complete one and clearly,like build the server,what we need from ISP and configure the zimbra it self,and configure in client side. i really hope that you would help me to solve my issue.thank you very much, and i’m waiting forward hearing from you sir..

    Regards
    Donald

    Comment by Donald — July 18, 2014 @ 8:49 AM

  84. Thank you very much. Excellent work and share. Been trying a lot of things from your blog.

    Comment by arnoldrodrigues — July 23, 2014 @ 6:58 AM

  85. Jhanzaidear sir, I ve got some broad band issue and here is it in nutsell

    1. I ve got three broad band connections at the office my office. (PSEB registered)
    2. since move over to the new location a few months ago frequent disconnection had been an issue.
    3.some line issuesvwere their but the Line man has been feed well and the line issues are since resolved.
    4. Th DSL guy is a hard worker and honest (my opinion) and if called will come on daily bases.

    problem:

    1. The router resets itself and looses all it setting. without any one messing with it. Ot resets Down to default.
    2. we usually keep a back up and each time it is restored it again loses the setting with in 5 minutes again.
    3. initially I thought it may be the routers so paid for new PTCL X3 router (new out of the box)
    4. The I got two DLINK routers and a netgear router and they all did the same.
    5. Then I though I might be getting hacked through wifi so I change to WPA2/WEP (didnt work)
    6. than i bought either net switch and switched completely to wire. (Some improvement)
    7. though not as frequent meaning no broadband all day it is now their for a few hours.
    8. I have put two stabilizer placed after a sign wave UPS (no luck) thought it may be power fluctuation. But no luck.

    In summary

    despite 7 routers, despite moving to cable, and despite almost daily resetting of the DSL log in pin (usually four digit) (log in remains the same) My router still resets and I mean reset down to factory default. This include brands of routers such as Tenda, Dlink, Netgear, Lynksys, and the new PTCL routers.

    Can you help by giving an advice.

    My opinion:

    I personnely think I am being hacked and user uses the log and password for free internet, as I am of the opiionion that PTCL is no longer using add on CLI function. You may know this as log in from your home or PTCL land line location location is no longer necessary (I think)

    It is also interesting that problem with internet between 2pm- 7pm time and that ramzan was trouble free 99 percent.

    I really need help and fast if possible.

    Thanks
    Imran

    Comment by imran rasool — August 29, 2014 @ 10:38 AM

  86. جناب آپ سے یہ پوچھنا ہے کہ جب اچانک لائٹ چلی جائے تو جو یوزر لاگ ان ہوتا ہے اسکی انفارمیشن محفوظ نہی ہوتی اگر ڈیوائس کو خود ری بوٹ کریں تو بھر ہوتی ہے اس مسلئے کا کوئی حل ؟؟ٹائم بھی چیک کیا تھا لیکن حل نہی ہوا

    Comment by Muhammad Asfand — September 2, 2014 @ 11:58 PM

  87. Dear Syed Jahanzaib, Is it possible to help me in my problem in the installation of Radius Manager 4.1.5 , Is it possible to help me through teamviewer ?? Please reply as soon as possible and this Email : alsakur@yahoo.com

    Comment by syed Tholfikar Ali — September 14, 2014 @ 10:40 PM

  88. Dear Syed Jahanzaib, Is it possible to help me in the installation of DMA SoftLab Radius Manager through the program teamviewer, for I have encountered a problem and needs to be resolved for a genius like you, note that I used the system Ubuntu 12.4 – 32bit desktop

    Comment by alsakur — September 15, 2014 @ 12:54 AM

  89. Dear friend
    kindly i see your topic on Squid and I have ubuntu server that i want to install squid3 can you do it for me and what is the cost for that ?
    you could contact me on vip_7alt_7ub@yahoo.com

    Comment by mustafa — October 10, 2014 @ 12:13 PM

  90. Dear Syed Jahanzaib I`m looking for a solution to my problem and i could pay for that. My problem is when a user connects in the hotspot if he has a HTTPS page set as main page i get a SSL error and its not redirected to the login page, but this doesnt happen with HTTP first pages. I’ve tried to redirect without success and i need to find a solution for this. Please contact me: jeanpablo.jp@hotmail.com

    Comment by Jean Pablo — October 15, 2014 @ 8:35 AM

    • Actually there is no CLEAN way to redirect ssl to hotspot, however there are workaround, but they require certification importation or PURCHASING of valid signed certificate.

      Comment by Syed Jahanzaib / Pinochio~:) — October 15, 2014 @ 9:57 AM

      • Im really interested on that…I have created one free certificate on this site https://www.startssl.com is that ok for try or do i need to buy one VeriSign certificate to test it???

        Comment by Jean Pablo — October 15, 2014 @ 10:16 AM

      • I get one valid signed certificate but it still don’t work… Please contact me: jeanpablo.jp@hotmail.com

        Comment by Jean Pablo — October 16, 2014 @ 3:50 AM

      • Syed Ji can u help me on p2p server

        Comment by genx1976 — December 5, 2015 @ 11:13 PM

  91. Im really interested on that…I have created one free certificate on this site https://www.startssl.com is that ok for try or do i need to buy one VeriSign certificate to test it???

    Comment by Jean Pablo — October 15, 2014 @ 10:05 AM

  92. Dear Syed, I would to contact you regarding DMASoftLab billing system. We are an ISP in india and planning to deploy this system. Would like to get few details on this from you. How do I contact you?

    Comment by Mohammad Mahefooz (@Mahefooz) — October 22, 2014 @ 9:44 AM

  93. Salaam bhai
    Mene apne pass squid proxy lagaya hai. Us mein aik problum a rahi kuch website jesay k visit4earn.com aur click4adds.com in ki bhi cache ban jati hai. Kia in ko bypass kr sakte hein? Aap k aik blog mein dekha tha is k bare mein per us ki koi samajh nahi ai. Pls reply me thank’s

    Comment by Adnan riaz — November 23, 2014 @ 11:19 AM

  94. You are being asked to login because timemojo@icloud.com is used by an account you are not logged into now.
    By logging in you’ll post the following comment to About ME:

    Hello, Syed.

    Recently i’ve configured my Mikrotik router to use PCC load balancing with dual pppoe wan access, i try to force all LAN user to use an internal DNS server, i’ve tried everything but none of them worked. Could you help me?

    The PCC guide i used:

    http://wiki.mikrotik.com/wiki/Manual:PCC

    My router LAN IP: 192.168.1.1
    My DNS IP: 192.168.1.2

    Sorry for my bad english

    Thank you very much.

    Comment by Zed — December 1, 2014 @ 8:01 PM

  95. Hi bro can you help me in configuring mail server with postfix,dovecot,mysql and roundcube.

    Comment by satish — December 23, 2014 @ 6:46 PM

  96. I have 2 Mikrotiks device that connected by IPIP tunnel and i can ping all my local Ip from both side. (IPIP tunnel is connected)
    From : 192.168.1.xxx can ping all range 192.168.2.xxx and also from 192.168.2.xxx can ping 192.168.1.xxx
    Now the problem is i want to connect by DSTNAT router 1 from out side to local IP of router 2 . that mean
    Router 1:
    chain=dstnat action=dst-nat to-addresses=192.168.2.200 to-ports=5900
    protocol=tcp dst-address=185.11.146.128 in-interface=PPPOE-Client-E2-128
    dst-port=6060 log=no log-prefix=””

    but it will not connect to local range router 2

    Router 1 :
    WAN Route 1: 185.11.146.128
    IP range Router 1 : 192.168.1.0/24

    Router 2 :
    IP Range Router 2 : 192.168.2.0/24

    Comment by Mahmoud — January 9, 2015 @ 12:43 PM

  97. Dears Sir i want to setup an iptv setting with my hotspot and ppoe running servers on mikrotik rb450g. Now i want to give access to watch my iptv some of client whoom i give permission to watch iptv along with internet and some of clients deny iptv access. How this is possible. When i activate upstreaming using igmp proxy iptv starts working on all clients pc. how to stop some clients and allow some clients.

    Comment by Tahir — February 7, 2015 @ 1:32 AM

  98. Hi Sir can you please assist me with something small?

    How do i allow P2P trough the mini isp setup?

    something is blocking it.

    thank you in advanced

    Comment by Ruan Jansen — April 3, 2015 @ 7:06 PM

  99. Sir
    i had these changeip update script for mikrotik v.6 , it was working and now no longer , can you help me to know why?

    #************************************************************************************************
    # Parameters
    #************************************************************************************************
    :local username “”
    :local password “”
    :local hostname “”

    #availabe options: “http” or “iface”
    # – http: will query an external server and discover you public ip (userful for NATted connections)
    # – iface: will use the ip address assigned to the $iface interface (see below)

    :local discoverBy “iface”

    # interface used to get ip address from (only if discoverBy = iface)

    :local iface “public-dsl”

    # current available services: “dyndns”, “noip” and “changeip”
    :local service “changeip”

    # number of days to force an update if your IP did not change (helps keeping your account active)
    :local forceUpdate 15

    #************************************************************************************************
    # do not change below this unless you know what you are doing
    #************************************************************************************************

    :local force
    :global lastUpdate
    :local currentIP

    :if ($discoverBy=”http”) do={
    /tool fetch mode=http address=”checkip.dyndns.org” src-path=”/” dst-path=”/dyndns.checkip.html”
    :local result [/file get dyndns.checkip.html contents]
    :local resultLen [:len $result]
    :local startLoc [:find $result “: ” -1]
    :set startLoc ($startLoc + 2)
    :local endLoc [:find $result “” -1]
    :set currentIP [:pick $result $startLoc $endLoc]
    } else={
    :set currentIP [ /ip address get [find interface=$iface disabled=no] address ]
    :for i from=( [:len $currentIP] – 1) to=0 do={
    :if ( [:pick $currentIP $i] = “/”) do={ :set currentIP [:pick $currentIP 0 $i] }
    }
    }

    #get IP from DynDNS for our hostname
    :local resolvedIP [:resolve $hostname]

    # get current date in format mm/DD/YYYY
    :local date [ /system clock get date ]

    # convert to YYYYMMDD
    :local months (“jan”,”feb”,”mar”,”apr”,”may”,”jun”,”jul”,”aug”,”sep”,”oct”,”nov”,”dec”);
    :local month [ :pick $date 0 3 ]; :local day [ :pick $date 4 6 ]; :local year [ :pick $date 7 11 ];
    :local mm ([ :find $months $month -1 ] + 1);
    :if ($mm = $forceUpdate && $forceUpdate > 0)) do={
    :set force true
    }

    :put (“Current IP: $currentIP ($discoverBy), Last update: $lastUpdate”)

    # Determine if dyndns update is needed
    :if (($currentIP != $resolvedIP) || ($force = true)) do={

    :if ($service = “dyndns”) do={
    /tool fetch user=$username password=$password mode=http address=”members.dyndns.org” \
    src-path=”/nic/update?hostname=$hostname&myip=$currentIP” dst-path=”/output.txt”
    }
    :if ($service = “noip”) do={
    /tool fetch user=$username password=$password mode=http address=”dynupdate.no-ip.com” \
    src-path=”/nic/update?hostname=$hostname&myip=$currentIP” dst-path=”/output.txt”
    }
    :if ($service = “changeip”) do={
    /tool fetch user=$username password=$password mode=http address=”nic.changeip.com” \
    src-path=”/nic/update?hostname=$hostname&myip=$currentIP” dst-path=”/output.txt”
    }

    :local result [/file get output.txt contents]
    :log info (“dynamic-dns-updater: Service = $service, Hostname = $hostname”)
    :log info (“dynamic-dns-updater: CurrentIP = $currentIP, Resolved IP = $resolvedIP”)
    :log info (“dynamic-dns-updater: Update result: “.$result)
    /ip dns cache flush
    :set lastUpdate $date
    }

    Comment by hadyatef — May 18, 2015 @ 3:22 PM

  100. salam bhai can you guide me how to build own wirless internet providing company fawad434@gmail.com thanks advanced

    Comment by fawad — July 3, 2015 @ 5:27 AM

  101. I want to discuses about one small hotspot network i heaved at Saudi Arabia Riyadh.
    I want some changes at server after discussion i want your cost demand kindly waiting for your response.
    Thanks.

    Comment by Abu — September 2, 2015 @ 11:27 PM

  102. I want to discuses about one small hotspot network i heaved at Saudi Arabia Riyadh.
    I want some changes at server after discussion i want your cost demand kindly waiting for your response.

    Comment by Abu Shahid Muhammad — September 2, 2015 @ 11:28 PM

  103. I have DMA Radius Manger installed on CentOS. I want integrate this radius server with Hotel Management System. I need your Professional Service. Please Help.

    Comment by Jafar Ali S. Momin — September 4, 2015 @ 5:41 PM

  104. AoA sir
    I have same problem with my vdsl router it hangs up time to time i also have mikrotik routerboard 750 can yu help me then plzz help me sir
    Because if i use router in bridge mood then where will i put my ptcl ppoe username and pasword ?
    Thanks🙂
    I will b gratefull to you🙂

    Comment by Talha — October 4, 2015 @ 9:13 PM

  105. Dear Syed Jahanzaib brother,

    This is Mohammad Fazle Rabbi from Bangladesh. I’m going to open a Mini WISP for a very rural area. Can you please help me configuring the equipment? I can pay if I can afford your fees. Please leave an email on mfrabbibd@gmail.com

    Jajak Allah Khayer.

    Comment by Md. Fazle Rabbi — October 9, 2015 @ 8:18 PM

  106. Hi Syed,
    I have been learning so much from your blog, especially about Mikrotik
    I see that you use The Dude.
    Do you know how to create a function on The Dude to ping IPv6 addresses?
    The only thing i was able to do is to create a tool for Winbox/SSH to connect IPv6.

    Thanks🙂.

    Comment by Wissam Quemel — October 22, 2015 @ 2:42 PM

  107. hello brother how are you bro my name is syed ali farhan naqvi i am from mandi bahauddin please send me your number on my facebook or on my mobile please bro i need some help please thanks http://www.facebook.com/farhanshah110 number 0340-452 2070

    Comment by Farhan Shah — October 25, 2015 @ 3:26 PM

  108. AoA….Did you have any thing about BW control over ubuntu server .I have setup and shred internet over LAN ?

    Comment by Feroz Akhtar — November 23, 2015 @ 4:53 PM

  109. Hi there. Great Blog Man! I was wondering if you could give me some pointers on a small issue. I have a mikrotik rb433ah and my wan is on ether1 and I have a server with static IP 192.168.10.100 that is connected to a switch that goes to ether3. I want to allow a outside user with a static internet IP (ex. 1.2.3.4) to connect to the server in ether3 on port 80. in winbox i have a nat rule set up but do i need a filter rule too?

    Thanks!

    Comment by miotx — December 10, 2015 @ 11:21 AM

    • you need FILTER only if you have some strict firewall in place.
      otherwise a simple NAT rule (dst-nat) would be fine enough.

      Comment by Syed Jahanzaib / Pinochio~:) — December 10, 2015 @ 12:40 PM

      • thats what i thought but its giving me issues because I want it to accept incoming connections from a specific IP from the internet… But it blocks it when I enter that IP in the src dress. I don’t want to leave it blank then anyone can login with that port…😦

        Comment by miotx — December 12, 2015 @ 4:19 AM

  110. Jazak Allah Khair

    Comment by Hesham Saad — January 4, 2016 @ 4:03 AM

  111. Alsalam Alaykom

    Please contact me for a freelance isp project.

    Comment by Mohammad — January 25, 2016 @ 4:06 AM

  112. Can you please contact me for a free lance project?

    Comment by Faizan — April 7, 2016 @ 2:15 AM

  113. jazak allaho khayran , thanks a lot sir

    Comment by sohaib — April 21, 2016 @ 2:55 PM

  114. Thanks for what you are offering. Jazakom Allah Kheir

    Comment by Rabih — May 5, 2016 @ 3:23 PM

  115. Aslam-0-Alikum

    I have (4Mb x 4) wan and I am using 5 port mikrotik . Now I want to add 2 more 4Mb wan like which router is avaliable in Pakistan rawalpindi to do load balancing for 6 wan. I check mikrotik website there is routers but I don’t know which model exactly available in Pakistan . I don’t want to do it on pc by adding NIC cards.

    Comment by Yasir khan — July 3, 2016 @ 9:44 PM

  116. Salam Sir.. Sir app ne jo load balancing failover ki technique batai ha MIKROTIK ki usey main ne follow kia ha aur wo successfully implement hua ha and working properly too. But sir problem sirf mje ye arahi ha ke multiple computers frequently bar bar apne WAN(INTERNET) change kartey rehtey hai .. Main chahta ho ke jab ke fail over na ho tab tak har computer single WAN pe hi chaley aur sirf fail over honey per hi jo apna WAN swtich karey Please help me Sir.

    Email ID : rahim.alii@outlook.com

    Comment by Rahim Ramzan Ali — October 21, 2016 @ 4:21 PM

    • Use src-address as classifier, this way you will get rid of problems like https/broken link, streaming issues etc. Load balancing using this PCC technique (src-address) will be effective and balanced approach when more and more connections (from clients) that occurred. it will work like following
      when user 1 will come he will be binded with the wan1, for that session
      when user 2 will come he will be binded with the wan2,for that session
      when user 3 will come he will be binded with the wan3.for that session
      when user 4 will come he will be binded with the wan4, for that session
      when user 5 will come he will be binded with the wan1, for that session

      and so on

      Comment by Syed Jahanzaib / Pinochio~:) — October 25, 2016 @ 9:31 AM

  117. Aslam-O-Alikum,
    Kesy ho ap sab log or Syed bhai ap, acha mera question ye hai k manny microtik routerboard ko pppoE py configuration kia hwa hai tu man wisnetwork or ubiquiti k outdoor cpe use kr k unko bridge bna kr nechy router lga k clients ko dy rha hon but man ye pochnna chahta hon k kia man , Local anteena with detachable anteena router k sath connect kr skta ho ya ye option sirf hotspot mai e hta hai ? Man rocket m2 or rocket m5 use kr rha hon with airmax sector k sath tu jo 500meter par clients hain unko local anteena with router k sath pppoE connect kr k dy skta hon ? Please reply karna bht Mehrbani ap ki

    Comment by zahid parvez — November 20, 2016 @ 10:28 PM

  118. Onething more please agr local anteena nhi use kr skta tu koi sb se cheap outdoor CPE bta dy 3000-4000pkrs ki range mai

    Comment by zahid parvez — November 20, 2016 @ 10:31 PM


RSS feed for comments on this post. TrackBack URI

Leave a Reply

Fill in your details below or click an icon to log in:

WordPress.com Logo

You are commenting using your WordPress.com account. Log Out / Change )

Twitter picture

You are commenting using your Twitter account. Log Out / Change )

Facebook photo

You are commenting using your Facebook account. Log Out / Change )

Google+ photo

You are commenting using your Google+ account. Log Out / Change )

Connecting to %s

Blog at WordPress.com.

%d bloggers like this: