Syed Jahanzaib Personal Blog to Share Knowledge !

March 16, 2015

Windows 7 WEATHER GADGET ‘not working’ workaround!

Filed under: Microsoft Related — Tags: , — Syed Jahanzaib / Pinochio~:) @ 12:40 PM

UPDATE: May, 2015

The method defined in this post is now not working any more. [at the beginning it was working but not anymore] , I will see if alternate methods may work and will update this post in coming week, to see if its working … Insha Allah,  




From past few days, clients reported that Weather gadget stopped working with error “cannot connect to service …






After doing some googling, it was revealed that dueto some security concerns Microsoft have discontinued it.  BUT  you can still Enable by following simple steps.

  1. Go to “C:\Users\USERNAME\AppData\Local\Microsoft\Windows Live\Services\Cache”
  2. Edit “Config.xml” by Right Click / EDIT
  3. Now donot change any thing & simply save it (CTRL+S or FILE -> Save) [without doing any modification]
  4. After 1-2 MINUTES, Restart the Gadget!



It will work Insha Allah !!!!





Syed Jahanzaib


  1. It worked for me, Thanks

    Comment by Nigel Walker — March 16, 2015 @ 6:27 PM

  2. Worked for me too, thank you!

    Comment by walt — March 19, 2015 @ 6:18 PM

  3. dear Syed, Im tryng to make mikrotik load balancing with 2 AP DHCP enabled. is it possible to make it with dynamic gateways?

    Comment by Ardiyansyah Arief — March 23, 2015 @ 1:57 PM

  4. no “Config.xml” showing in cache folder.

    Comment by sarang — March 25, 2015 @ 9:19 PM

  5. AOA Syed Jahanzaib Bahi kesay hain ap sir mujhe ap ki kuch help chiye menay Cable net chalayi howei hai or Squid proxy server or Mikrotik lagaya howa hai mikrotik par PPPOE server or Hotspot configure kia howa hai user manager k sath ab problem yeh hai jo pppoe wale client or jin ko main Static IP do wo to Cached Content full speed mein jatey hain but jo hotspot wale user hain un ko nahi jate

    /ip firewall mangle> print detail
    Flags: X – disabled, I – invalid, D – dynamic
    0 ;;; Mark Cache Hit Packets
    chain=prerouting action=mark-packet new-packet-mark=proxy-hit passthrough=no dscp=12

    /queue tree> print detail
    Flags: X – disabled, I – invalid
    0 ;;; Cache Content Delivery @ Full Speed for Clients
    name=”pmark” parent=global-out packet-mark=proxy-hit limit-at=0 queue=default priority=8 max-limit=0 burst-limit=0 burst-threshold=0 burst-time=0s

    Comment by Jalil Abbas — March 26, 2015 @ 2:44 PM

    • how you are forwarding clients to squid? specific subnet or how ? maybe you are missing hotspot client in squid dst-nat rule.

      Comment by Syed Jahanzaib / Pinochio~:) — March 28, 2015 @ 11:13 AM

      • /ip firewall nat
        add action=masquerade chain=srcnat comment=”Masquerade Direct Internet Traffic” disabled=no src-address=
        add action=masquerade chain=srcnat comment=”PPPOE-Pool Masquerade” disabled=no src-address=
        add action=dst-nat chain=dstnat comment=”Redirect to SQUID” disabled=no dst-port=80 protocol=tcp to-addresses= \

        Nat Rule

        Comment by Jalil Abbas — March 28, 2015 @ 11:43 AM

  6. I just tried and it worked. Thx

    Comment by SamanthaSpade — April 7, 2015 @ 10:59 AM

    • When I searched internet for this problem , none of any worked,
      only this method worked strangely🙂 which means not one solution can be applied for every one
      Glad to know it helped you to solve the issue🙂

      Comment by Syed Jahanzaib / Pinochio~:) — April 11, 2015 @ 3:05 PM

      • salam jahanzaib mari file hi nahi hai yar iss folder may what can i do ?

        Comment by Waleed Khan — September 28, 2015 @ 6:50 PM

  7. Thanks it work for both laptop & main computer.
    I went thou 3-pages before I found yours.
    Again thanks.

    Comment by harpvj — April 8, 2015 @ 6:18 AM

  8. AOA. Can’t able to find “Config.xml” file in the cache folder. Can u please tell me any solution?

    Comment by Faisal Shamim Ahmed — April 14, 2015 @ 1:48 AM

  9. It is giving the weather of UK in place of Faisalabad Pakistan

    Comment by Ihsan Ul Haq — April 20, 2015 @ 10:43 PM

  10. fixed but can’t change location.

    Comment by istolethisname — April 29, 2015 @ 11:11 AM

  11. hi, i don’t get the option to edit (right click on file) the file im using windows 7 ultimate

    Comment by Carpn — April 29, 2015 @ 11:48 PM

  12. My Windows Weather gadget hadn’t been working for three days, but after following these instructions it is working again, and hopefully for more than just a little while. In any case, thank you, Syed, for this post.

    Comment by PCuserFromKansas — May 4, 2015 @ 9:11 AM

    • Since I posted on May 4 (elapsed time 7 days), I have had to do this two more times. Each time the gadget works again, but then a few days later it stops working. I don’t mind redoing it, since I like it to show the current local temp on my desktop, but I’m sure in a short time that process will become tedious. Having said that, I’d prefer it to work rather than not, so I guess I’ll keep doing it until it stops working altogether.

      Comment by Mary Brohammer — May 11, 2015 @ 11:21 AM

    • I thought I would update my update. This is still working for me as Syed describes, EXCEPT that every four days (regular as clockwork) it stops working and I have to redo it. I don’t restart the gadget–after a couple minutes it updates and then I’m okay for four days. For me it keeps the location I have set–I’m not having the “wrong location but unchangeable” problem that others have reported here. (I am running Windows 7) Thank you Syed. Good luck all!

      Comment by PCuserFromKansas — September 3, 2015 @ 9:56 PM

  13. Thanks you it worked

    Comment by Jawwad Baig — May 4, 2015 @ 6:13 PM

  14. Once fix is done, the location reverts back to a NY and a change cannot be made. Is there a way to change location back to the correct city?

    Comment by Eric — June 2, 2015 @ 5:36 PM

  15. I didn’t even have to restart it. Just re-saved that config file and a minute later the weather appeared. Thank You!

    Comment by Gord Smith ⛔ (@elgordo99) — June 2, 2015 @ 10:31 PM

  16. no “Config.xml” showing in cache folder
    plz hellp

    Comment by Maqbool — June 18, 2015 @ 12:15 PM

  17. Worked for me. Thank you!

    Comment by scottmatics (@scottmatics) — July 27, 2015 @ 8:03 PM

  18. Why did this work…???

    Comment by fred — July 29, 2015 @ 5:00 AM

  19. Well done! It worked first time I tried it, immediately. So simple! Thanks so much.

    Comment by Walter — September 1, 2015 @ 7:46 PM

  20. Dear Syed.

    gadgets (weather) can not find my location “peshawar”

    Comment by Hamid Ali — October 26, 2015 @ 1:12 PM

  21. Still works for me. Thank you.

    Comment by Georgepie — October 29, 2015 @ 1:42 AM

  22. The problem seems to have something to do with the time-date stamp of the Weather gadgets “config.xml” file.
    This batch file updates that time-date stamp from almost any location on the Windows C:\ drive.
    Copy and paste the text below into a new text file and then change the file extension from .txt to .bat
    Run it whenever the Weather gadget crashes wait a few minutes and or choose zip code again.
    Seems to work every time on many Win7 computers

    rem Touched! – Fixes Weather Gadget by updating “config.xml” file time-date stamp
    cd %userprofile%\AppData\Local\Microsoft\Windows Live\Services\Cache\
    COPY /B config.xml +,,

    Comment by BlueDream23 — January 19, 2016 @ 10:47 PM

RSS feed for comments on this post. TrackBack URI

Leave a Reply

Fill in your details below or click an icon to log in: Logo

You are commenting using your account. Log Out / Change )

Twitter picture

You are commenting using your Twitter account. Log Out / Change )

Facebook photo

You are commenting using your Facebook account. Log Out / Change )

Google+ photo

You are commenting using your Google+ account. Log Out / Change )

Connecting to %s

Blog at

%d bloggers like this: